Bug 36342 - Configuring partitions on Mylex RAID disks problematic
Configuring partitions on Mylex RAID disks problematic
Product: Red Hat Linux
Classification: Retired
Component: MAKEDEV (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-17 15:19 EDT by David Tonhofer
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-17 15:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2001-04-17 15:19:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


This is a standard PC-PIII 500MHz with an Intel motherboard
and a DAC960 RAID solution from Mylex (a PCI-SCSI card with 
three harddisks attached, uses RAID level 5, BIOS 4.10-41).


0) Decided to set up Linux RD7.0

1) Tried to set up the external SCSI disk drives as controlled
   by the DAC960 controller. Partitioned the drive using fdisk. 
   (For the layout: see below)
   After I quit fdisk, the setup program (anaconda?) gives an
   error from fdisk: 
   "An error occurred reading the partition table for the block
    device rd/c0d0. The error was: no free resources".

   --> How do I find out what kind of resources it needs?

   Had to "skip" the device and install everything on /dev/hda

2) Tried to set up RAID device from within the freshly installed
   RH7.0 Linux. Partitioned /dev/rd/c0d0 using fdisk into 
   3 primary (of which one swap) + 1 extended partition (with 5 
   Then called up mkfs on each of the /dev/rd/c0d0p{1...9} except
   the for extended partition, /dev/rd/c0d0p4.
   Noticed that /dev/rd/c0d0p9 does not exist, so I did 'mknod'.
   After that, for c0d0p8 and c0d0p9, Linux balks with the msg:
   "device not configured while trying to determine filesystem

   --> Do I have to rebuild the kernel for c0d0p8 & c0d0p9?
       I think not.

   Notice that mkfs /dev/c0d0 works, so I guess there is no
   problem with the geometry (128 heads, 32 sectors, 8715
   cylinders for a total of 17430MB)

3) I tried various configurations of the partitions...
   anything up to /dev/c0d7 works.
Comment 1 Arjan van de Ven 2001-04-17 15:21:39 EDT
Not a kernel bug, but MAKEDEV (which makes the /dev stuff)
Comment 2 Nalin Dahyabhai 2001-06-26 14:46:11 EDT
The kernel imposes a limit of 7 logical partitions per drive.  There are no
device numbers allocated for partitions beyond that.

Note You need to log in before you can comment on or make changes to this bug.