Bug 363641 - (Caracuri) - "-" at the start of URL don't work , don't connect to the host
- "-" at the start of URL don't work , don't connect to the host
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
http://caracuri.altervista.org/blog
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 08:00 EDT by Antonio
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 196852 None None None Never
Mozilla Foundation 402290 None None None Never

  None (edit)
Description Antonio 2007-11-02 08:00:37 EDT
Description of problem:
this url on linux don't work http://--galaxiagxa--.forumcommunity.net/

How reproducible:
put this in URL
Actual results:
can't resolve the host

Expected results:
is there a solution?

Info : i know that "-" can't be at the biginning of the site
http://www.faqs.org/rfcs/rfc952.html 
but i don't understand why it can't be fixed
Comment 1 Matěj Cepl 2007-11-02 09:18:18 EDT
We think, that issue being controversial should be better resolved upstream.
Please file a bug report in the the upstream bugzilla located at
http://bugzilla.mozilla.org in the Firefox product.

Once you've filed your bug report to the upstream bugzilla, if you paste the new
bug URL here, Red Hat will continue to track the issue in the centralized
upstream bug tracker, and will review any bug fixes that become available for
consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 3 Matěj Cepl 2007-11-04 10:00:06 EST
The upstream bug was closed as duplicate of
https://bugzilla.mozilla.org/show_bug.cgi?id=196852, which is closed as
VERIFIED/INVALID.

Although (to my surprise)
both

host -- --galaxiagxa--.forumcommunity.net
and
host -- -etcetera.city.fi

gives meaningful answer (I am not sure, whether it is the one you want -- it
leads to some kind of domain name provider or something of that sort for the
first name; I am testing this on Rawhide.) I cannot imagine that we would like
to maintain a substantial part of Firefox networking protocol in the
distribution. Closing as UPSTREAM and please try to persuade upstream to fix it
into your liking.

Note You need to log in before you can comment on or make changes to this bug.