Bug 363721 - imaps is broken
Summary: imaps is broken
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ruby   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Akira TAGOH
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-02 12:41 UTC by Jakub Hrozek
Modified: 2010-10-18 17:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 00:45:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (198 bytes, application/x-ruby)
2007-11-02 12:41 UTC, Jakub Hrozek
no flags Details

Description Jakub Hrozek 2007-11-02 12:41:15 UTC
Description of problem:
Discovered when testing net::imap as part of RHEL4 async advisory - try 
running the attached reprodurer. With newer ruby version shipped by RH (F7, 
for instance, it runs fine), however, it does spits exceptions.

Version-Release number of selected component (if applicable):
ruby-1.8.1-7.EL4.8.1

How reproducible:
always

Steps to Reproduce:
1. run the attached testcase
  
Actual results:
Resp: #<Net::IMAP:0x2aaaaae40de8>
/usr/lib/ruby/1.8/net/imap.rb:884:in `initialize': undefined method
`verify_mode=' for #<OpenSSL::SSL::SSLSocket:0x2000000000762328>
(NoMethodError)
         from ruby-imaps.rb:7:in `new'
         from ruby-imaps.rb:7

Expected results:
something along the lines of:
S: * OK Gimap ready for requests from 62.40.79.66 z33if1561272ikz

Comment 1 Jakub Hrozek 2007-11-02 12:41:15 UTC
Created attachment 246681 [details]
reproducer

Comment 2 Akira TAGOH 2007-11-09 03:04:24 UTC
this should be fixed in next release.

Comment 3 Jakub Hrozek 2007-11-09 14:40:52 UTC
Yes, seems to be fixed with the recent changes to net::imap to fix #362081. 
Sorry for the fuss, feel free to close this bug now.


Note You need to log in before you can comment on or make changes to this bug.