Bug 36382 - Postfix passes mailbox_size_limit to LDA as rlimit
Postfix passes mailbox_size_limit to LDA as rlimit
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: postfix (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 20:06 EDT by Damien Miller
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 09:01:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damien Miller 2001-04-17 20:06:28 EDT
After installing RH7.1, I noticed that all deliveries to mailbox files of
50Mb started failing. After some kludging around with procmail (which
really should log errno on failed writes), I noticed that postfix's
mailbox_size_limit was being passed to procmail as a RLIMIT_FSIZE.

Setting mailbox_size_limit to an arbitrary large value worked around the
problem for me, but postfix should be fixed to reset rlimit before firing
off the LDA.
Comment 1 Daniel Roesen 2001-04-18 04:23:40 EDT
AFAIK that's just intended behaviour. That's what mailbox_size_limit is for in
the first place.
Comment 2 Damien Miller 2001-04-20 08:39:33 EDT
It wasn't expected behaviour in any case (I would expect an implicit size limit
to apply only to postfix's own LDA), and it was painful to debug because
procmail doesn't log errno for failed writes to mboxes even in verbose mode.
Comment 3 Daniel Roesen 2001-04-20 08:58:42 EDT
intended (by the author) != expected (by the user)

We had this discussion on postfix-user mailinglist. Wietse's mails lead me to
the claim that it is _intended_ behaviour by the author.

If you want to have different semantics you've got to contact Wietse
(wietse@porcupine.org) or even better discuss on postfix-users mailing list.

I still think RESOLVED/NOTABUG is the correct resolution.
Comment 4 Daniel Roesen 2001-04-20 09:00:54 EDT
BTW: you can disable the limit by

mailbox_size_limit = 0

Note You need to log in before you can comment on or make changes to this bug.