Bug 364071 - doesn't handle daemon restarts cleanly
doesn't handle daemon restarts cleanly
Status: CLOSED DUPLICATE of bug 323051
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-pulse (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 11:40 EDT by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 12:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-11-02 11:40:05 EDT
1. have PA normally started
2. start rhythmbox playing (using gst-pulse)
3. pause RB
4. kill PA
5. restart PA
6. unpause RB

RB then hangs; needs to be killed and restarted.

pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
rhythmbox-0.11.2-10.fc8
Comment 1 Lennart Poettering 2007-11-07 10:53:29 EST
Uh. How should this ever work? Why did you kill PA in the first place? If you
just want PA to give up the audio device, there's "pasuspender" which can do
this temporarily for you.

I mean, have you seen what happens if you kill "gnome-session"? Or
"dbus-daemon"? Most apps cannot deal with having the XSM or D-Bus restart
either. Sure, it would be nice if clients would automatically reconnect. But
come on. If you want to shoot yourself in the foot by killing PA, do you really
expect that gst-pulse will tape over this?

Comment 2 Bastien Nocera 2007-11-07 11:30:16 EST
I don't think anyone is expecting it to work, but at least an error message
would be better than hanging the application (which is then going to be blamed
for the hang).
Comment 3 Pierre Ossman 2007-11-07 12:05:32 EST
Also, the daemon might not be local, so network problems might also cause a
disconnect.
Comment 4 Bug Zapper 2008-04-04 10:22:47 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Lennart Poettering 2008-04-07 12:50:35 EDT

*** This bug has been marked as a duplicate of 323051 ***

Note You need to log in before you can comment on or make changes to this bug.