Bug 36419 - Hangs on bootup after system installs
Hangs on bootup after system installs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 01:49 EDT by Greg LaPolla
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 20:23:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg LaPolla 2001-04-18 01:49:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


APM Daemon hangs when system is booted.  Unable to determine exact cause.  
Short term fix boot to single user mode init 1 on the lilo command line 
and disable apm.  System will then boot fine.

The system is a compaq Presario 1670
AMD 350Mhz
64 Megs of Ram.

Latest bios from compaq is installed

Reproducible: Always
Steps to Reproduce:
1.boot up system
2.
3.
	

Actual Results:  System hangs

Expected Results:  System should boot normally to logon prompt

No error messages given by apm
Comment 1 Bernhard Rosenkraenzer 2001-04-18 17:36:21 EDT
This is almost certainly a problem with your BIOS ("current" and "working" can 
be two quite different things), since it works everywhere else.
It's definitely not an apmd problem, all apmd does is taking care of executing 
scripts when the apm status changes (e.g. when you pull the plug or put the 
machine into suspend).
Reassigning to kernel, because that's (1) where the problem might be if it 
isn't a BIOS bug after all, and (2) it's where workarounds for the problem 
could go (Mike: what do you think about disabling apm on some blacklist 
BIOSes?)


Comment 2 Arjan van de Ven 2001-04-18 17:39:06 EDT
Bios-specific APM blacklist is planned and currently under development by the
linux APM maintainer
Comment 3 Arjan van de Ven 2001-04-19 17:00:04 EDT
as an extra workaround: rpm -e apmd  :)
Comment 4 Greg LaPolla 2001-04-20 02:46:15 EDT
Well,  it worked fine under redhat 6.2.  So I dont see how this can be a bios 
issue.  It could be something that was interduced in the 2.4 kernel apm 
routines.  Since it did work on redhat 6.2, I dont how this could be a 
blacklisted bios.  I will try to dig into it more this weekend.  And see if I 
can get some more info as to what is locking up when apmd loads.

Comment 5 Greg LaPolla 2001-09-04 23:57:32 EDT
Is there a resolution to this yet ?
Comment 6 Arjan van de Ven 2001-09-05 03:22:09 EDT
you could try booting with "apm=off" on the commandline.
The difference between older kernels (eg 2.2 kernels as in 6.2 and 7.0) is that
the kernel currently  trusts the APM bios to comply to the standard a bit more
to get extra information and powersaving (eg when the system is idle).
Comment 7 Greg LaPolla 2001-09-05 07:48:50 EDT
It doesnt do this on debian or Mandrake with newer kernels  however redhat 7.2 
beta is a litle better, at least it boots, it will lock anytime the apm command 
is used.  It onoly appears to be specific to redhat.  My question is it going 
to be fixed ?
Comment 8 Arjan van de Ven 2001-09-05 07:55:52 EDT
We don't have ANY patches against the APM code. So the only question is which
config options are different. I'll check the latest Mandrake kernel; the only
thing I can think of is that they have the ALLOW_IRQ option different; that can
be overriden at boottime by adding a 

apm=allowints     (7.1)
apm=allow_ints    (7.2)

to the kernel commandline.
Comment 9 Greg LaPolla 2001-09-05 19:29:07 EDT
Using apm=allow_ints    on redhat 7.2 doesn't help issuing apm at the shell 
prompt causes the system to lock up.  

apm should return back the battery status  or at least thats what it used to 
return.


Comment 10 Greg LaPolla 2001-09-10 00:19:05 EDT
Well,  I have found the fix sorta.  After hacking around with the 2.4.7 source 
all weekend I downloaded 2.4.9 kernel.  I only applied the ext3 patches.  And 
built the kernel using the same options that are used to build the i386 verion 
except I used the k6 arch instead and omitted the options that are added by the 
patches.  All is good now.  So eaither there is a bug in the 2.4.7 kernel or 
you are creating a bug with patches you apply to the kernel.

Also on another note the kernel pcmcia based drivers choke on my laptop when a 
cardbus card is inserted, works fine with 16 bit cards.  So I recompiled with 
out pcmcia and installed the latest pcmcia-cs drivers from David Hines and all 
works good.  I think I am working at 100%.  I am still testing things.


Note You need to log in before you can comment on or make changes to this bug.