Bug 3642 - X server will not start using Trident 3DImage975 video card (XFree86-
X server will not start using Trident 3DImage975 video card (XFree86-
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Depends On:
  Show dependency treegraph
Reported: 1999-06-22 14:44 EDT by bjhanneg
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-31 17:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description bjhanneg 1999-06-22 14:44:49 EDT
It appears that an application is attempting to access the X
server before it is started, or that the permissions set by
the XFree86- rpm may be incorrect. Reinstalling
XFree86- is a workaround for this.

There are no error messages prior to the message below (this
is a complete dump)

_X11TransSocketUNIXConnect: Can't connect: errno = 111
waiting for X server to begin accepting connections

XFree86 Version / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 4 1999
	If the server is older than 6-12 months, or if your card is
	than the above date, look for a newer version before
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-15smp i686 [ELF]
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 0):
      NV1, STG2000, RIVA128, RIVATNT, ET4000, ET4000W32,
      ET4000W32i_rev_b, ET4000W32i_rev_c, ET4000W32p,
      ET4000W32p_rev_b, ET4000W32p_rev_c, ET4000W32p_rev_d,
ET6000, ET6100,
      et3000, pvga1, wd90c00, wd90c10, wd90c30, wd90c24,
wd90c31, wd90c33,
      gvga, ati, sis86c201, sis86c202, sis86c205, sis86c215,
      sis5597, sis5598, sis6326, tvga8200lx, tvga8800cs,
      tvga8900c, tvga8900cl, tvga8900d, tvga9000, tvga9000i,
      tvga9200cxr, tgui9400cxi, tgui9420, tgui9420dgi,
      tgui9440agi, cyber9320, tgui9660, tgui9680, tgui9682,
      cyber9382, cyber9385, cyber9388, cyber9397, cyber9520,
      3dimage985, clgd5420, clgd5422, clgd5424, clgd5426,
      clgd5429, clgd5430, clgd5434, clgd5436, clgd5446,
clgd5480, clgd5462,
      clgd5464, clgd5465, clgd6205, clgd6215, clgd6225,
clgd6235, clgd7541,
      clgd7542, clgd7543, clgd7548, clgd7555, clgd7556,
ncr77c22, ncr77c22e,
      cpq_avga, mga2064w, mga1064sg, mga2164w, mga2164w AGP,
      mgag100, oti067, oti077, oti087, oti037c, al2101,
ali2228, ali2301,
      ali2302, ali2308, ali2401, cl6410, cl6412, cl6420,
cl6440, video7,
      ark1000vl, ark1000pv, ark2000pv, ark2000mt, mx,
realtek, s3_virge,
      AP6422, AT24, AT3D, s3_svga, NM2070, NM2090, NM2093,
NM2097, NM2160,
      NM2200, ct65520, ct65525, ct65530, ct65535, ct65540,
ct65545, ct65546,
      ct65548, ct65550, ct65554, ct65555, ct68554, ct69000,
      ct64300, mediagx, V1000, V2x00, p9100, spc8110,
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc104"
(**) XKB: layout: "us"
(**) XKB: variant: "nodeadkeys"
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
(**) SVGA: Graphics device ID: "Video"
(**) SVGA: Monitor ID: "Monitor"
(**) FontPath set to
.(--) SVGA: PCI: Trident 3DImage975 rev 243, Memory @
0xe5400000, 0xe5800000
(--) SVGA: Revision 3.
(--) SVGA: TV interface is NTSC
(--) SVGA: DAC is enabled for TV
(--) SVGA: VGA display is connected.
(--) SVGA: Using Trident programmable clocks
(**) SVGA: chipset:  3dimage975
(**) SVGA: videoram: 4096k
(**) SVGA: Using 8 bpp, Depth 8, Color weight: 666
(--) SVGA: Maximum allowed dot-clock: 230.000 MHz
(**) SVGA: Mode "1024x768": mode clock =  65.000
(--) SVGA: There is no mode definition named "800x600"
(--) SVGA: Removing mode "800x600" from list of valid modes.
(**) SVGA: Mode "640x480": mode clock =  25.175
(--) SVGA: Virtual resolution set to 1024x768
(--) SVGA: Generic SpeedUps selected (Flags=0x30)
(--) SVGA: Using Linear Frame Buffer at 0x0e5400000, Size
(--) SVGA: Using Graphics Engine.
(--) SVGA: Using 1024 byte display width.
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: Using 8 128x128 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and non-transparent stipples
(--) SVGA: XAA: Horizontal and vertical lines and segments
Comment 1 Derek Tattersall 1999-06-29 11:39:59 EDT
Are you attempting to start X via xdm/gdm? Or by "startx" from the
command line?
Comment 2 Preston Brown 1999-07-15 16:51:59 EDT
So you are saying that X doesn't start at all, or just that it starts
but is giving you this error message?  The error message is a
side-effect from a race-condition work-around fix, and can be safely
ignored.  But if X isn't starting at all, that is indicative of some
other problem that we need to fix.
Comment 3 Preston Brown 1999-08-31 17:05:59 EDT
closed due to lack of feedback.  Works fine here.
Comment 4 sharifi 1999-10-14 12:43:59 EDT
I have problem the same problem. I use XFree86-3.3.5-3 but I can not
use X server. I try redhat 6.0 and 6.1 but I have the same problem.
After installing redhat I use Xconfigurator and when it creates
XF86Config file for me I edit it to delete the Modeline that are not
compatible with my monitor then I entre startx command. The screen
appears but after few seconds when it try to load some thing related
to gnome my screen becomes white or black, my computer becomes blocked
and force to reboot my computer.

Note You need to log in before you can comment on or make changes to this bug.