Bug 36423 - mouseconfig dumps core
mouseconfig dumps core
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 03:43 EDT by jouni
Modified: 2007-04-18 12:32 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jouni 2001-04-18 03:43:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)


I have MS Cordless wheel mouse on ps/2.

I did an upgrade 7.0 -> 7.1  Anaconda was unable to probe my mouse.
(I think that I answered MS intellimouse on text-based menu showing 
afterwards).  

But when starting X cursor jumps allover.  My mouse was configured as 
generic ps/2 mouse.  When now running mouseconfig I get following:

mouseconfig: line 5 unexpected in /etc/sysconfig/mouse
             Error on Read
             There was an error reading the file /etc/sysconfig/mouse.

             Would you like to proceed in creating a new configuration?

Answering yes does does not create new configuration file.

When I deleted /etc/sysconfig/mouse, running mouseconfig dumps core every 
time when run.

Creating manually some /etc/sconfig/mouse resolved the problem and allowed 
me to configure the mouse.


Reproducible: Always
Steps to Reproduce:
1.  Delete /etc/sysconfig/mouse
2.  Run mouseconfig
3.
	

Actual Results:  core dump.

MS cordless wheel ps/2 mouse on SMP system.
Comment 1 Jason Kirtland 2001-04-18 22:07:25 EDT
This problem also occurs with my Microsoft Trackball Explorer plugged in via a 
USB to PS/2 adapter.  Interestingly, I believe I had configured the mouse as a 
PS/2 mouse, but mouseconfig reported it as set as a USB version*. I tried to 
change it back, but got an "unexpected line in /etc/sysconfig/mouse" error.  I 
deleted the file, now it dumps core.  Perhaps the detector is detecting it as a 
USB mouse (which it is), but not taking into account the fact that its in the 
PS/2 port?

Mine is NOT on an SMP system.  Its a standard Dell PIII desktop, circa August 
2000.

*  Turns out the keyboard locks when you've got a PS/2 mouse and the system is 
expecting a USB mouse.  This was really fun since "gpm" is set to run in 
runlevel 3 (locks at login prompt), and there is a default firewall preventing 
network access.. grrr.
Comment 2 Jason Kirtland 2001-04-18 22:29:51 EDT
Pulled the USB->PS/2 converter off the mouse, and everything works fine now- 
detection via kudzu, X, etc.  I've also replicated the original problem with 
another USB->PS/2 mouse combo (Intellimouse Explorer).
Comment 3 Brandon Yap 2001-04-20 02:42:32 EDT
I upgraded from 7.0 to 7.1, ran into the problem while starting Xconfigurator 
(it tries to read /etc/sysconfig/mouse) and tried to find a workaround.
Here's the results.
To avoid this message when running mouseconfig on RH7.1, delete line 5 
entirely. I've looked at my RH7.0 /etc/sysconfig/mouse and it doesn't include 
the 5th line. I tried it and it works.
It also dumped core on me once when I tried to run it. But I deleted the mouse 
file, and on subsequent executions, it probed and found the mouse. Strange.
Comment 4 Need Real Name 2001-04-23 18:13:39 EDT
I have similar problems when attempting to make a new workstation installation of
Red Hat 7.1 work on a 200 Mhz Pentium Pro (Intel VS440FX board) with 196 MB RAM.

I can reproduce the coredump when deleting the /etc/sysconfig/mouse file. 
I cannot get it to probe on subsequent attempts though.

When deleting line 5 i the /etc/sysconfig/mouse file I can run mouseconfig.
But no matter what I choose - I have a Microsoft PS/2 Intellimouse - one of the early versions 
and I have tried both with a generic PS/2 mouse and with a Microsoft PS/2 Intellimouse -
but no matter what i have tried then Gnome/KDE is completely frozen upon startup.

Removing the mouse completely enables Gnome/KDE starting up however of course with very
limited mouse-less functionality.

If I do not manually disable APM during startup then it is even frozen already at the first shell logon-prompt!

The motherboard does not support USB - so here I have a PCI card supporting USB for a HP 5300C 
scanner. Could this be the problem given the problems mentioned in other bug-reports about PS/2 
mouses being confused with USB mouses and vice versa ?

My installation is now disintegrating because of the many "unproper" reboots - so will probably have 
to do all again from scratch.

Any help would be most appreciated!
Comment 5 Per Winkvist 2001-04-24 01:51:17 EDT
Applies to me to except that I believe I didn't get a core dump. I only get 
the "line 5 unexpected in /etc/sysconfig/mouse ..."

Comment 6 John Killian O'Brien 2001-04-26 09:01:22 EDT
I have a logitech trackman marble wheel connected to a USB port and get similar problems.
My computer is a Dell OptiPlex GX1 (i686), none of the following was a problem with 7.0

Upgrade from 7.0 -> 7.1 seemed to go ok, Anaconda recognised the type of mouse correctly and I
selected "Generic 3 button (USB)" from the list as my exact model wasn't listed.

Both gnome and kde freeze (especially when using netscape) but also sometimes during login. I've
tried different mouse settings but with no success, usually making things worse.

When I run /usr/sbin/mouseconfig I get the message "line 5 unexpected in /etc/sysconfig/mouse"
and a screen saying that there was a problem with the file and would I like to configure my mouse
now. I click yes and then am brought straight to a screen asking to I want to update the X config.
Again I click yes, but nothing has changed. Rerunning mouseconfig produces exactly the same
behaviour. It has never produced a core dump.

/etc/sysconfig/mouse looks like this...

/etc/sysconfig/mouse
MOUSETYPE="ps/2"
XMOUSETYPE="IMPS/2"
FULLNAME="Generic 3 Button Mouse (USB)"
XEMU3=no
DEVICE=/dev/mouse

The relevant section from /etc/X11/XF86Config look like this...

Section "Pointer"
  Protocol "IMPS/2"
  Device "/dev/mouse"
  ZAxisMapping 4 5
# Lots of stuff commented out
EndSection
Comment 7 Jojo 2001-05-07 08:44:29 EDT
I have a Logitech wheel mouse(optical) on an Athlon GHz (just normal stuff)
everything worked fine with 7.0 but after installing 7.1 I also got the "line 5
meaasge" and afterwards a core dump. I tried to delete the /etc/sysconfig/mouse
and it didnt work first but after a reboot kudzu found and configured the mouse
I still cant use the mouseconfig comand.
Comment 8 Need Real Name 2001-05-12 01:05:45 EDT
I have the same problem using a generic ps/2 mouse.  The mouse is recognized 
fine during installation, but after booting up for the first time it is 
unrecognized.  I have tried three different mice and the problem is identical 
regardlesso of the manufacturer. I have applied the following patches from 
Redhat.   
ftp://updates.redhat.com/7.1/en/os/i386/Xconfigurator-4.9.29-1.i386.rpm
ftp://updates.redhat.com/7.1/en/os/i386/mouseconfig-4.22-1.i386.rpm
neither of these patches were able to get the system to recognize the mouse.  I 
am at the point where I want to pack up the box and send it back to the 
company.  RedHat support has been no help.  Anyone have any suggestions on how 
to fix this problem.
Comment 9 Need Real Name 2001-06-04 20:49:17 EDT
I've been able to reproduce the line 5 unexpected error in /etc/sysconfig/mouse
on every redhat-7.1 system I've tested it on by doing the following:

1. run mouseconfig as root, select an option.
2. run mouseconfig again, and the line 5 error occurs.

Deleting the /etc/sysconfig/mouse file results in a core dump.

Here are the mice that I have seen the problem with:

Logitech TrackMan Marble FX (PS/2)
Microsoft Intellimouse (PS/2)
Logitech Cordless TrackMan FX (PS/2 with USB->PS/2 adapter)
Generic PS/2 mouse.(PS/2)
Logitech MouseMan Serial (Serial, ttyS0)

I would conclude that this problem isn't mouse/machine specific.
Comment 10 Kevin Arnold 2001-06-08 23:10:28 EDT
I have the same problem here.  With the following /etc/sysconfig/mouse,
mouseconfig exits with the error reading line 5 error.  
% cat mouse
MOUSETYPE="imps2"
XMOUSETYPE="IMPS/2"
FULLNAME="Microsoft IntelliMouse (PS/2)"
XEMU3=no
DEVICE=/dev/mouse

Note that this file was created by mouseconfig itself, so mouseconfig is able to
generate a file that it cannot read.  If I comment out the last line,
mouseconfig works fine.
Comment 11 Alexei Podtelezhnikov 2001-06-09 15:27:14 EDT
I've seen some similar mouse problems yesterday too. Fixed that by playing with 
bios:

                Bad setup          Good setup
Plug-n-play OS    Yes                No    
Clear NVRAM       No                 Yes
Comment 12 Need Real Name 2001-08-30 12:25:09 EDT
I have the same problem using a generic serial mouse.  The mouse is recognized 
fine during installation, but after booting up for the first time the pointer 
is in a"semi-frozen" state meaning it does not follow the movements of the 
mouse and moves very slowly.  I have tried two different mice and the problem 
is identical 
regardless of the manufacturer. I have applied the following patches from 
Redhat.   
ftp://updates.redhat.com/7.1/en/os/i386/Xconfigurator-4.9.29-1.i386.rpm
ftp://updates.redhat.com/7.1/en/os/i386/mouseconfig-4.22-1.i386.rpm
neither of these patches were able to make the mouse work properly . 
Comment 13 Need Real Name 2001-09-26 16:51:03 EDT
Basically, I have an Intel P4 system using D850GB motherboard
(Intel motherboard).  The mouse I have is an MS 3-button (wheel)
optical mouse with a cord to the PS/2 port.  The mouse middle
button (Wheel) does not work. I only have left and right button.
The middle buttone seems inactive.  The Linux 7.1 OS has
configured the mouse as a generic ps/2 mouse.  Like others, I tried
to use mouseconf also and got the same errors, tool complaints and
core dumps.  In the meantime I have many tools requiring the middle
mouse button but cannot use them as a result. Some the these tools
include: Pointwise GridGen V13.3.11, NASA's Chimera OVERGRID tool,
NASA's PLOT3D tool, etc.  How is this bug hunt going?
Comment 14 Mario Minutolo 2001-09-27 12:47:55 EDT
I have the same problem as most of you, but I don't remember any core dump. My 
PC is P133 64Mb, with ps2 mouse. When I try to use the mouse on my linux box 
everithing freezes.

First I thought was a system hang but I succedded in a ssh connection from a 
win98 machine with cygwin/xfree and after killing gpm I recovered control over 
the machine. 

So the problem is no input is processed from keyboard and mouse, since key 
sequences I tried to type appeared after gpm was killed.

Is quite unnerving using my win98 to control linux. How could I help this bug 
resolution? 
Comment 15 Need Real Name 2001-10-02 13:01:21 EDT
Along the same lines, I have found that while installing V7.1, the microsoft 
ps/2 wheel mouse installs properly on an Intel Pentium 400Mhz machine.

However, if a KVM switch is used, then the mouse takes off to the upper right 
corner and just lays there. The KVM switch is MiniView 2-port produced my ATEN.
The same KVM and mouse on a K6-2 266Mhz machine does not have this problem.

V6.2 does not have this problem with the KVM switch. So something has changed 
between V6.2 and V7.1.The above problems have only been observed during a new 
installation. No use of mouseconf has been attempted, in large part due to all 
the problems described in this thread.

Hopefully this V6.2 is OK versus V7.11 is not OK, may help to identify the 
problem.
Comment 16 R P Herrold 2001-10-17 11:37:34 EDT
Also true with a Compaq marque two-button mouse ...
Comment 17 R P Herrold 2001-10-17 11:47:00 EDT
Workaround (tested and working) for the problem:

The 'remove line 5' (taht is, remove the pointer: DEVICE=/dev/mouse)  and rerun
the Xconfigurator will then work, and leave a useful XF86config.  



Comment 18 Teemu Ikonen 2002-02-25 03:14:18 EST
I have Logitech Optical Mouse with USB connection and the symptoms are identical (error reading line 5 and coredump). However, mouse works with XFree86 after manual configuration.
Comment 19 Brent Fox 2002-10-10 14:16:29 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 20 Red Hat Bugzilla 2006-02-21 13:47:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.