Bug 36427 - Memory loss/eating with XFree86 applications
Memory loss/eating with XFree86 applications
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 04:33 EDT by Joshua West
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 11:25:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua West 2001-04-18 04:33:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)


I'm not sure exactly where its coming from, but I lose much memory when
using GUI applications in X... I have 256mb RAM, and on my initial
graphical login, about 205 is free.  However, the more graphical
applications I run (like netscape, especially netscape), the less memory is
there after I close the application.  When I have 205 free, I'll load
netscape, go to about 5 sites, close netscape, only to find that I now have
190mb RAM free.  I'm running RH7.1 on a dual pentium III-800mhz machine w/
256mb RAM.  I'm also running no desktop managers and Enlightenment as my
window manager (added /etc/X11/gdm/Sessions/Enlightenment).

Reproducible: Always
Steps to Reproduce:
1. Login to X
2. Run graphical applications, such as netscape
3. Close the applications
	

Actual Results:  Memory loss - see description.

Expected Results:  Memory should be freed correctly.

If you need any more information just drop me an email.
Comment 1 Sammy 2001-04-18 11:25:13 EDT
What is your graphics card? What driver are you using? There seems to be an
unidentified memory leak somewhere...this is known to be true for (unsupported)
NVIDIA drivers (not nv) and perhaps some matrox drivers although I have not been
able to get back to person who reported the matrox problem.
Comment 2 Mike A. Harris 2001-04-18 13:36:13 EDT
Linux does not work like that.  Free memory is *wasted* memory.  Memory is
a valuable resource, and if it is sitting around doing nothing then it is
wasted, as such, Linux maximizes the usage of memory by keeping all memory
busy at all times - minus a meg or two for fast allocation.  When you
reboot your system, and it comes up, most memory is free.  So it will remain
so until something uses it.  The kernel uses free memory for buffer/disk
caching, so once the system has been running for a short period, ALL memory
should be showing up used.  This is 100% correct operation.

On another note, if you look at "top" or "ps" output you may notice the "X"
process showing a large number for "SIZE" of memory used.  This number is NOT
the amount of RAM being used.  It includes the size of your video memory,
and memory mapped i/o registers, etc.  The output of "top" and "ps" are thus
misleading.

What you are seeing is normal proper behaviour.  There is no memory leak.

Comment 3 Sammy 2001-04-18 15:09:57 EDT
That is true for the total memory but how about individual processes?

When I use the nv driver X *always* shows around 65MB and when konqueror
is loading a very large page it goes up to 53MB.

When I switch to NIVIDA drivers X shows around 188MB and loading the same
page with konqueror takes it upto 300MB's. At that point I can just watch the
system start to hang and freeze (384MB ram). So, you do get some info from top. May be
it is not a leak....but considering the number of people reporting the same
problem here and in news groups indicate that there is something wrong. So far
I saw this problem mostly with NVIDIA drivers plus one guy reporting Matrox but
I could not get back to him. That is why I was wondering if this person is using
the NVIDIA as well.


Comment 4 Joshua West 2001-04-18 15:29:17 EDT
Hrm... it seems I'm not able to reproduce the problem anymore after upgrading to
Netscape 4.77 via the RHN.  Closing Netscape brings me back to 205mb free.  Do
you think that it was possibly a netscape problem?  I think so, because I
noticed that the more pages I went to, the more memory was eaten, and there was
no bottom limit.
Comment 5 Joshua West 2001-04-18 15:29:48 EDT
BTW, graphics card is ATI Rage 2000 Pro (128bit, 32mb RAM)
Comment 6 Sammy 2001-04-19 09:55:17 EDT
I don't think it was Netscape problem since I had the problem with Konqueror, more
likely some library they were compiled against....presumably fixed before 4.77 was
compiled.

Note You need to log in before you can comment on or make changes to this bug.