Bug 364331 - iptables leaks a file descriptor before fork/exec
iptables leaks a file descriptor before fork/exec
Status: CLOSED DUPLICATE of bug 312191
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 13:48 EDT by Tim Fenn
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 11:13:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Fenn 2007-11-02 13:48:44 EDT
Description of problem:

iptables is not closing open file descriptors before calling fork/exec - see
discussion on fedora-selinux list:

https://www.redhat.com/archives/fedora-selinux-list/2007-October/msg00033.html

Version-Release number of selected component (if applicable):

iptables-ipv6-1.3.8-2.1.fc7
iptables-1.3.8-2.1.fc7

How reproducible:

always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

tried to file on iptables/netfilter bugzilla page
(http://bugzilla.netfilter.org/), but it seems to be nonfunctional.
Comment 1 Thomas Woerner 2007-11-05 11:13:59 EST

*** This bug has been marked as a duplicate of 312191 ***

Note You need to log in before you can comment on or make changes to this bug.