Bug 364481 - update scsi-target-utils
update scsi-target-utils
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: scsi-target-utils (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Mike Christie
:
: 319171 442782 (view as bug list)
Depends On: 467731
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 15:18 EDT by Mike Christie
Modified: 2009-01-20 15:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The iSCSI target capability, delivered as part of the Linux Target (tgt) framework, moves from Technology Preview to full support in Red Hat Enterprise Linux 5.3. The linux target framework allows a system to serve block-level SCSI storage to other systems that have a SCSI initiator. This capability is being initially deployed as a Linux iSCSI target, serving storage over a network to any iSCSI initiator. To set up the iSCSI target, install the scsi-target-utils RPM and refer to the instructions in: /usr/share/doc/scsi-target-utils-[version]/README and /usr/share/doc/scsi-target-utils-[version]/README.iscsi
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated initscript for tgtd (2.08 KB, text/plain)
2008-09-26 14:03 EDT, IBM Bug Proxy
no flags Details
sysconfig file for tgtd (117 bytes, text/plain)
2008-09-26 14:03 EDT, IBM Bug Proxy
no flags Details
Example target.conf file (412 bytes, text/plain)
2008-09-26 14:03 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Mike Christie 2007-11-02 15:18:48 EDT
Description of problem:

scsi-target-utils is only a tech preview in 5.1, because it lacks basic features
like being able to do a persistent setup (no config file like iet). It also has
some performance issues and needs more testing. This bugzilla is so we can bring
in these improvements being worked on upstream and at readhat, to RHEL 5.2.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2007-11-02 15:24:42 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 RHEL Product and Program Management 2008-06-02 16:29:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Mike Christie 2008-09-19 13:52:21 EDT
Updated in scsi-target-utils-0.0-5.20080917snap.el5.
Comment 8 Tom Coughlan 2008-09-26 13:54:04 EDT
*** Bug 442782 has been marked as a duplicate of this bug. ***
Comment 9 Tom Coughlan 2008-09-26 13:55:09 EDT
If all goes well during 5.3 beta, the the iSCSI target will move from tech. preview to full support in 5.3 GA. Please test this thoroughly and report results here.
Comment 10 IBM Bug Proxy 2008-09-26 14:03:36 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-04-16 14:14 EDT
1. Feature Id:	[201627]
Feature Name:	Promote scsi-target-utils from tech preview
Sponsor:	LTC
Category:	System Storage
Request Type:	Driver - Feature from Vendor

2. Short Description
The scsi-target-utils is in TechPreview status in RHEL5.2 .  We would like to request this package
to be upgraded to normal supported status in RHEL5.3 .

Part of this request involves fixing Bugzilla Bug 43092 - Redhat Bugzilla 437201- iSCSI - missing
CHAP support in Anaconda.

3. Business Case
scsi-target-utils is in TechPreview mode in RHEL5.2 and thus unsupported.
As it is unsupported, we have no RHEL supported iSCSI packages we can implement at user and
customer sites since supportability
is a requirement.
Availability of a supported iSCSI target solution for RHEL5.3 would open business and use case
opportunities for us, which would otherwise be unavailable.

4. Sponsor Priority
IBM Confidential:	no
Code Contribution:	no
Upstream Acceptance:	Accepted
Component Version Target:	scsi-target-utils
Performance Assistance:

5. PM Contact:	Stephanie Glass, sglass@us.ibm.com, 512-838-9284

6. Technical contact(s):
Daisy Chang, daisyc@us.ibm.com
Michael Anderson, mike.anderson@us.ibm.com

7. LTC Manager: Wendel Voigt, wvoigt@us.ibm.com


Based on feedback received the team making the request can use the package as it
so there is no code changes required for IBM. Moving bug to submitted.

Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.

IBM is requesting that Red Hat reconsider this request.  Later today we will
update with more information on why.


Red Hat,
Could you please give us more details on your concerns? Is there a resource
problem or a code stability/supportibility issue on your side for this feature?

We'd like to make sure that you understand that the request is simply to
ship the RPMs as-is. IBM has performed reasonable amount of integrated testing
with it and found no issues so far. I'm sure that the test scenarios and
results can be made available for your review. Will it help on the RHEL5.3
inclusion? Please let us know. Thanks.

Please

The primary concern from engineering is that it is not polished enough. At the
very least we need a way allow the user to setup a persistent configuration
where they would set some values like the luns and target settings, and when
they reboot the box the those settings are used again.

There are also some bugs in the newer code. We could probably have these fixed
in time though.

- We were going to rebase against the current git head, and in our testing we
found that when running multiple sessions at the same time and pulling cables,
if the task management functions are executed or if we go into session level
recovery tgtd will segfault.

I think the TMF issue was recently solved, but the session level recovery tgtd
segault has not been fixed yet.

- In light testing the current git code, we found tgtd segfaulting when just
doing a dd to a iscsi disk.

From Ronnie Sahlberg at IBM:

Hi,

Just a quick followup.

The root cause of these SEGVs have been pacthed in the current git tree of
STGT. So these  crashes should not occur any more.

Second, while it would not be important to us, but maybe for RedHat,
Richard Sharpe (of Panasas) has agreed to maintain the configuration tool
and configuration file for STGT   so the issue with a .conf file will
eventually be resolved as well.

regards
ronnie sahlberg
-------------------------------------------------------------------------
Have you tried the latest GIT?

(In reply to comment #10)
> From Ronnie Sahlberg at IBM:
>
> Hi,
>
> Just a quick followup.
>
> The root cause of these SEGVs have been pacthed in the current git tree of
> STGT. So these  crashes should not occur any more.
>
> Second, while it would not be important to us, but maybe for RedHat,
> Richard Sharpe (of Panasas) has agreed to maintain the configuration tool
> and configuration file for STGT   so the issue with a .conf file will
> eventually be resolved as well.
>
>
> regards
> ronnie sahlberg
> -------------------------------------------------------------------------
> Have you tried the latest GIT?

Is IBM asking us to try the latest stgt git tree, or was the something in the
email sig?

It seems like IBM did not get our comments a while back about what to help on,
because I marked it private. Here was the old comment:

<start>
............................

It looks like my primary concern of persistent configuration is going to be
solved upstream by the perl based parser. If IBM could test that, and test the
target (use what is in the upsteam git tree) it would be great.

1. Test muliptath configs.
2. Multiple sessions.
3. Error paths. TMFs and session level recovery code paths with multiple sessions.
4. Fix shutdown issues. Add code to init scripts for clean shutdowns.
5. Test restarts if the target while initiatos are logged in.

.........................................
<end>

So we agree on the config issue, and thenzl@redhat.com on the BZ and stgt list,
is working on killing bugs and other fun stgt stuff so as you guys saw on the
list we also agree on the SEGV issue.


Red Hat,
Thanks for your feedback. The five sets of tests you listed sounds good. IBM
will commit to perform those tests. Ronnie Sahlberg <sahlberg@au1.ibm.com> is
the lead for this effort. The plan is to start it in early September. Once the
test is done, we'll post the results here.

Hope that this addresses your concern. If there is anything else, please let
us know.











Update

I have tested and confirmed the following works :
1. Test muliptath configs.
2. Multiple sessions.
3. Error paths. TMFs and session level recovery code paths with multiple sessions.
5. Test restarts if the target while initiatos are logged in.

1,2,3 were all tested using multipathing to a LUN uing multiple sessions, one
session for each connection/path.

Applications were configured to do I/O the LUN while a fault was introduced on
the active path, making it inoperable.
As expected, after a timeout multipathd detects the path is faulty and fails
over to the redundant session/path. At this stage access to the LUN is restored
and the application continues.

5 was tested by    kill -9 and restarting the tgtd daemon while initiators are
performing I/O to the LUN. This was tested for both single session/pathing and
multiple sessions/pathing from nthe initiator.

4 will require some additional review and possibly code fixes to the init
script. This will be addressed shortly.


Can this feature please be reevualated for inclusion into RHEL 5.3.

Red Hat requested IBM to do 5 test items to have this reconsidered.  We have
done 4 out of  5 already and have now documented this in the bug, the 4th item
we are working on but it will take a while longer to complete which is also
documented.  Is there anyway to have this feature reconsidered now then
most of the work is done by IBM and we will complete the work shortly.


I have attached three files to this bug.

It addresses the "shutdown" issue (item 4 in the list of tasks) by using the
tgtadm command to stop/shutdown tgtd instead of using the kill command.
You can not "stop" tgtd when there are initiator logged into a target.
You can however use "service tgtd forcedstop" which will forcefully log-out all
connected initiators and shutdown tgtd.

During "start" the initscript will invoke tgt-admin and read the target/lun
configuration file and set up tgtd accordingly.

Configuration is held in /etc/sysconfig/tgtd and there are two current settings :
1, the name of the configuration file. defaults to /etc/tgt/targets.conf
2, whether or not FCOE service shall be offered and if so on which interface.

It adds an example tgtd configuration that serves as an example for users
wanting to configure tgtd.

The scsi-target-utils update for 5.3 was done under bug 364481. If all goes well during 5.3 beta, the the iSCSI target will move from tech. preview to full support in 5.3 GA. Please test this thoroughly and report results in BZ 364481.

*** This bug has been marked as a duplicate of 364481 ***
Comment 11 IBM Bug Proxy 2008-09-26 14:03:42 EDT
Created attachment 317818 [details]
Updated initscript for tgtd

This is an updated initscript for TGTD. 
It adds a clean shutdown of tgtd using the tgtadm command instead of using the
kill command.
It also invokes the tgt-admin tool on start to set up the targets and luns
used.
Comment 12 IBM Bug Proxy 2008-09-26 14:03:47 EDT
Created attachment 317819 [details]
sysconfig file for tgtd

This is an example sysconfig file for tgtd. It is used by the new initscript.
Comment 13 IBM Bug Proxy 2008-09-26 14:03:52 EDT
Created attachment 317820 [details]
Example target.conf file

This is /etc/tgt/targets.conf.sample, an example tgt configuration file.

This file describes one iSCSI target and one LUN and serves as an example for
users that want to configure tgtd.
Comment 14 IBM Bug Proxy 2008-11-08 15:50:49 EST
I have done a lot of testing on the codebase for STGT which mike c cut into the planned RPMs.

I am happy with the functionality and have not found any bugs which will affect our use-case.

I have also tested and used the rc-scripts that me and mike c and others developed for the target and am happy with these scripts and how they provide a proper mechanism to start/stop the daemon.

Thanks for upgrading this to a GA package.  My tests of the code base have been successful.
Comment 15 Tom Coughlan 2008-12-08 15:57:19 EST
*** Bug 319171 has been marked as a duplicate of this bug. ***
Comment 16 Tom Coughlan 2008-12-08 16:24:59 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The iSCSI target capability, delivered as part of the Linux target (tgt) framework (scsi-target-utils package), moves from technical preview to full support in RHEL 5.3. 

The Linux target (tgt) framework allows a system to serve block-level SCSI storage to other systems that have a SCSI initiator. This capability is being initially deployed as a Linux iSCSI target, serving storage over a network to any iSCSI initiator.

To set up the iSCSI target, install the scsi-target-utils RPM and refer to the instructions in:

* /usr/share/doc/scsi-target-utils-[version]/README
*/usr/share/doc/scsi-target-utils-[version]/README.iscsi

Replace [version] with the corresponding version of the package installed.

For more information, refer to man tgtadm.
Comment 18 Ryan Lerch 2008-12-08 20:46:28 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,12 +1,2 @@
-The iSCSI target capability, delivered as part of the Linux target (tgt) framework (scsi-target-utils package), moves from technical preview to full support in RHEL 5.3. 
+The iSCSI target capability, delivered as part of the Linux Target (tgt) framework, moves from Technology Preview to full support in Red Hat Enterprise Linux 5.3. The linux target framework allows a system to serve block-level SCSI storage to other systems that have a SCSI initiator. This capability is being initially deployed as a Linux iSCSI target, serving storage over a network to any iSCSI initiator.
-
+To set up the iSCSI target, install the scsi-target-utils RPM and refer to the instructions in: /usr/share/doc/scsi-target-utils-[version]/README and /usr/share/doc/scsi-target-utils-[version]/README.iscsi-The Linux target (tgt) framework allows a system to serve block-level SCSI storage to other systems that have a SCSI initiator. This capability is being initially deployed as a Linux iSCSI target, serving storage over a network to any iSCSI initiator.
-
-To set up the iSCSI target, install the scsi-target-utils RPM and refer to the instructions in:
-
-* /usr/share/doc/scsi-target-utils-[version]/README
-*/usr/share/doc/scsi-target-utils-[version]/README.iscsi
-
-Replace [version] with the corresponding version of the package installed.
-
-For more information, refer to man tgtadm.
Comment 19 IBM Bug Proxy 2008-12-11 09:11:18 EST
This has already been verified, closing bug.
Comment 21 Ryan Lerch 2009-01-11 18:49:32 EST
this requires_release_notes flag for this one has been changed back to ?, but no comment was left detailing the change required for this note. Setting the flag back to +, if changes are required, please re-set the flag to ?
Comment 22 errata-xmlrpc 2009-01-20 15:55:32 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0099.html

Note You need to log in before you can comment on or make changes to this bug.