Bug 364611 - implantisomd5 has wrong "usage" information
Summary: implantisomd5 has wrong "usage" information
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-02 20:16 UTC by Jonathan Reed
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 19:21:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Reed 2007-11-02 20:16:28 UTC
Description of problem:

When run without any arguments, /usr/lib/anaconda-runtime/implantisomd5 displays the following 
sample "usage" information:

:~$/usr/lib/anaconda-runtime/implantisomd5 
implantisomd5:         implantisomd5 [--force] [--supported] <isofilename>

However "--supported" is not a valid argument:

:~$/usr/lib/anaconda-runtime/implantisomd5 --supported
bad option --supported: unknown option

The option is actually named "--supported-iso"


Version-Release number of selected component (if applicable):

:~$rpm -qv anaconda-runtime
anaconda-runtime-10.1.1.13-1

How reproducible:

Always

Steps to Reproduce:
1.  Run /usr/lib/anaconda-runtime/implantisomd5 --supported /path/to/some/iso/image
2.  See it report that "--supported" is an unknown option

Actual results:

:~$/usr/lib/anaconda-runtime/implantisomd5 
implantisomd5:         implantisomd5 [--force] [--supported] <isofilename>


Expected results:

:~$/usr/lib/anaconda-runtime/implantisomd5 
implantisomd5:         implantisomd5 [--force] [--supported-iso] <isofilename>


Additional info:

Comment 1 Jonathan Reed 2007-11-05 16:13:21 UTC
I've changed this to RHE5, since the bug also occurs there in anaconda-runtime-11.1.2.36-1.  

Comment 2 Chris Lumens 2007-11-20 19:21:53 UTC
This will be fixed in the next build of anaconda for Fedora and for the next
major release of RHEL.  Thanks for the bug report.


Note You need to log in before you can comment on or make changes to this bug.