This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 364861 - Kyum error when listing and updating packages
Kyum error when listing and updating packages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kyum (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 19:24 EDT by Russ
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-04 14:37:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russ 2007-11-02 19:24:28 EDT
Description of problem: 
When Kyum encounters packages with formatting issues it causes an error with a
traceback, and issues a code 1. This prevents listing or updating the packages
below the one with the formatting which causes the error. The error occurs only
in Kyum and does not occur using the current Yum revision in text mode 

Version-Release number of selected component (if applicable):
kyum-0.7.5-7.fc7

How reproducible:
always

Steps to Reproduce:
1. enable repositories with package formatting issues (all, including fedora,
fedora updates)
2. kyum list updates

  
Actual results:
*** Traceback (most recent call last):
***   File "/usr/bin/yum", line 29, in <module>
***     yummain.main(sys.argv[1:])
***   File "/usr/share/yum-cli/yummain.py", line 105, in main
***     result, resultmsgs = base.doCommands()
***   File "/usr/share/yum-cli/cli.py", line 282, in doCommands
***     return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
***   File "/usr/share/yum-cli/yumcommands.py", line 171, in doCommand
***     rup = base.listPkgs(ypl.updates, 'Updated Packages', basecmd)
***   File "/usr/share/yum-cli/output.py", line 129, in listPkgs
***     self.infoOutput(pkg)
***   File "/usr/share/yum-cli/output.py", line 100, in infoOutput
***     print _("Description:\n%s") % enc(pkg.description)
***   File "/usr/share/yum-cli/output.py", line 84, in enc
***     if len(s) > 0:
*** TypeError: object of type 'NoneType' has no len()
Process exited normally with code 1.

Expected results:
Process exited normally with code 0.

Additional info:
See  Bugzilla Bug 249994: yum updating --> TypeError: list objects are
unhashable for similar Yum issue in text mode.
Comment 1 Jochen Schmitt 2007-11-04 14:37:23 EST
This is a dupe of Bug 249994

Note You need to log in before you can comment on or make changes to this bug.