Bug 3650 - klock (KDE screen blanker/locker) not YP-compatible
klock (KDE screen blanker/locker) not YP-compatible
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-22 19:27 EDT by eric
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-23 12:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description eric 1999-06-22 19:27:13 EDT
The KDE screen blanker/locker does not read authentication
information via NIS, meaning that on workstations like ours
(where all workstations are identical, NFS-mounting home
directories, DHCP'ing their IP addresses, and getting
authentication info via NIS) accidentally hitting the little
'lock' button on the KDE button bar really does lock it --
permenantly. (Well, control-alt-backspace logs the user out,
but that's no real answer).

Works fine for locally-authenticated users. The "real"
(unpatched) KDE should work fine for YP, since it uses the
getpwent in the libc library by default (which is
NIS-compatible). Problem with the PAM patches?
Comment 1 Preston Brown 1999-09-23 12:59:59 EDT
we have no problems using PAM locally here at Red Hat, and having PAM
authenticate against local files and NIS/YP.  Are you sure you haven't
misconfigured your PAM set up?

my passwd: line in nsswitch.conf is just a simple "files nisplus nis".

/etc/pam.d/kde contains:

#%PAM-1.0
auth       required     /lib/security/pam_pwdb.so shadow nullok
auth       required     /lib/security/pam_nologin.so
account    required     /lib/security/pam_pwdb.so
password   required     /lib/security/pam_cracklib.so
password   required     /lib/security/pam_pwdb.so shadow nullok
use_authtok
session    required     /lib/security/pam_pwdb.so
session    optional    /lib/security/pam_console.so debug

It is used to authenticate for kdm and the kde screensavers.

my /etc/pwdb.conf (the pam_pwdb module is used to authenticate) has
the following:

#
# This is the configuration file for the pwdb library
#

user:
        unix+shadow
        nis+unix+shadow

group:
        unix+shadow

nis+unix+shadow

These are all the stock, shipped defaults.

Note You need to log in before you can comment on or make changes to this bug.