Bug 36501 - weird handling of symlinks
Summary: weird handling of symlinks
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-18 15:29 UTC by Gerald Teschl
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 17:35:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-04-18 15:29:51 UTC
If I cd into a directory which is a symlink, bash2 (pwd,tab completion)
will predent that
my current wd is the symlink, but for all other command its the real
direcory. This is extremely
confusing!

Comment 1 Matthew Miller 2001-04-18 17:35:20 UTC
also \w in PS1.

Comment 2 Bernhard Rosenkraenzer 2001-04-18 21:29:03 UTC
It's not a bug, it's a setting - if you don't like it, "set -o physical" in 
your .bashrc.



Note You need to log in before you can comment on or make changes to this bug.