Bug 365091 - Option given to move files that are read-only [Can't be moved]
Option given to move files that are read-only [Can't be moved]
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-03 06:41 EDT by lexual
Modified: 2008-01-13 06:36 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-13 06:36:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lexual 2007-11-03 06:41:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Epiphany/2.18 Firefox/2.0.0.8

Description of problem:
Option given to move files that are read-only [Can't be moved]

Version-Release number of selected component (if applicable):
2.18.3

How reproducible:
Always


Steps to Reproduce:
Nautilus allows users to try and move read-only files.
This shouldn't be allowed because:
1) Trying so will fail, and you will only achieve a copy operation.
2) It is impossible to move something that is read-only, because you can't delete it.

Try this:
Middle click a read-only file and drag to a writable folder.
Given options to copy, link, move, cancel.

The option to move should be disabled.

If I do try to move the file will copy and then I see this error dialog.
Error while moving.
"FILENAME" cannot be moved because it is on a read-only disk.
[Cancel Button] [Retry Button]

I don't know what the retry button is meant to do.
If nautilus knows that the file is on a read-only disk, why user to move it.
Is is already impossible to "cut" read-only files, moving operations should be the same.

The above behaviour will occur when Shift-dragging a read-only file and should be disabled.


Actual Results:


Expected Results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.