Bug 365101 - Crash when dragging clip to timeline
Crash when dragging clip to timeline
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pitivi (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-03 06:59 EDT by W. Michael Petullo
Modified: 2008-01-11 17:00 EST (History)
0 users

See Also:
Fixed In Version: 0.11.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:00:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2007-11-03 06:59:18 EDT
Description of problem:
Pitivi crashes when I try to drag a DV clip to the timeline. The following error
is printed:

/usr/share/pitivi/python/pitivi/pitivi.py:158: GtkWarning:
gtk_text_layout_get_iter_at_position: assertion `GTK_IS_TEXT_LAYOUT (layout)' failed
  gtk.main()
/usr/share/pitivi/python/pitivi/pitivi.py:158: GtkWarning: Invalid text buffer
iterator: either the iterator is uninitialized, or the
characters/pixbufs/widgets in the buffer have been modified since the iterator
was created.
You must use marks, character numbers, or line numbers to preserve a position
across buffer modifications.
You can apply tags and insert marks without invalidating your iterators,
but any mutation that affects 'indexable' buffer contents (contents that can be
referred to by character offset)
will invalidate all outstanding iterators
  gtk.main()
Segmentation fault

Version-Release number of selected component (if applicable):
pitivi-0.10.3-2.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Import a raw DV clip into pitivi
2. Drag the clip and drop it onto the timeline
  
Actual results:
Pitivi crashes with the error message above.

Expected results:
The clip should be placed on the timeline.

Additional info:
I built a local copy of pitivi version 0.11.0. This version does not have this
problem.
Comment 1 Fedora Update System 2007-11-06 11:04:05 EST
pitivi-0.11.0-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pitivi'
Comment 2 Fedora Update System 2007-12-10 15:47:47 EST
pitivi-0.11.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pitivi'
Comment 3 Jeffrey C. Ollie 2007-12-10 17:17:31 EST
Mike, can you confirm if the 0.11.0 or 0.11.1 builds fixed your problems?
Comment 4 W. Michael Petullo 2007-12-12 03:02:27 EST
Confirmed fixed in 0.11.1-1.fc8.
Comment 5 Fedora Update System 2008-01-11 17:00:41 EST
pitivi-0.11.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.