Bug 365141 - Review Request: iotop - Top like utility for I/O
Review Request: iotop - Top like utility for I/O
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ignacio Vazquez-Abrams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-03 07:57 EDT by Adel Gadllah
Modified: 2009-10-21 14:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-03 13:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ivazqueznet: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Adel Gadllah 2007-11-03 07:57:29 EDT
Spec URL: http://tgmweb.at/gadllah/iotop.spec
SRPM URL: http://tgmweb.at/gadllah/iotop-20070930-1.fc7.src.rpm
Description:
Linux has always been able to show how much I/O was going on
(the bi and bo columns of the vmstat 1 command).
iotop is a Python program with a top like UI used to
show of behalf of which process is the I/O going on.
Comment 1 Ignacio Vazquez-Abrams 2007-11-03 08:12:32 EDT
iotop-20070930-1.fc7.noarch.rpm:
iotop.noarch: W: no-documentation

iotop-20070930-1.fc7.src.rpm:

Use "install -p -m 0755" instead of cp and chmod.
Comment 2 Adel Gadllah 2007-11-03 08:21:47 EDT
Fixed version (version is 0.1)
Fixed %install 
New package:
http://tgmweb.at/gadllah/iotop.spec
http://tgmweb.at/gadllah/iotop-0.1-1.fc7.src.rpm
Comment 3 Ignacio Vazquez-Abrams 2007-11-03 08:32:54 EDT
Approved.
Comment 4 Adel Gadllah 2007-11-03 08:36:34 EDT
New Package CVS Request
=======================
Package Name: iotop
Short Description: Top like utility for I/O
Owners: drago01
Branches: F-7 F-8
Cvsextras Commits: yes
Comment 5 Kevin Fenzi 2007-11-03 13:27:50 EDT
cvs done.
Comment 6 Jeremy West 2009-01-26 11:57:41 EST
Package Change Request
======================
Package Name: iotop
New Branches: EL-4 EL-5
Owners: drago01
Comment 7 Kevin Fenzi 2009-01-26 18:06:43 EST
iotop requires python 2.5, which neither EL4 nor EL5 have. 
Did you find some way to port it back to previous python versions?
Comment 8 Jeremy West 2009-01-26 21:26:10 EST
Kevin,

No I did not.  Just cancel this request.

Thanks
Comment 9 Adel Gadllah 2009-01-27 10:58:06 EST
(In reply to comment #7)
> iotop requires python 2.5, which neither EL4 nor EL5 have. 
> Did you find some way to port it back to previous python versions?

The python version issue might be fixable, but the kernel support is missing in RHEL4/5 too..

So no this package is not suitable for EPEL until RHEL6 is released.

Note You need to log in before you can comment on or make changes to this bug.