Bug 36518 - Mounting NFS exported vfat filesystems fails with latest kernel
Mounting NFS exported vfat filesystems fails with latest kernel
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 13:12 EDT by Manfred Hollstein
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-05 04:54:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2001-04-18 13:12:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1 i686)


Attempting to mount a directory via NFS from a server fails, when that
directory is
locally mounted on the server using the "vfat" type.

Reproducible: Always
Steps to Reproduce:
1.On the server running kernel-2.2.19, mount -t vfat
-ouid=1000,gid=100,umask=002,quiet,uni_xlate /dev/hda2 /dos/c
2.On any client, mount server:/dos/c /mnt
3.
	

Actual Results:  1. is performed successfully.
2. results in an error message
  mount: server:/dos/c failed, reason given by server: Permission denied
on the client, and in the following log entry on the server:
  Apr 18 19:08:18 server rpc.mountd: authenticated mount request from
172.16.2.13:906 for /dos/c (/dos/c) 
  Apr 18 19:08:18 server rpc.mountd: getfh failed: Operation not permitted

And yes, I have a line

/dos/c          172.16.2.0/255.255.255.0(rw,no_root_squash)

in my /etc/exports file on the server.

This worked successfully until I installed the latest kernel-2.2.19 update.
2.2.17 didn't have
any problems with this.
Comment 1 John Dalbec 2001-08-16 13:07:16 EDT
Ditto reiserfs.
Comment 2 John Dalbec 2001-08-16 13:12:14 EDT
Oops, I meant to say I get this error NFS exporting reiserfs filesystems with
kernel 2.4.3-15 (courtesy arjanv).  I installed -15 to fix the reiserfs umount
bug in -12.
Comment 3 John Dalbec 2001-08-16 13:48:03 EDT
Sorry, I had assumed 'service nfs restart' = 'service nfs stop; service nfs
start'.  Apparently this is not the case.  NFS/ReiserFS mounting works now.
Comment 4 Manfred Hollstein 2002-05-05 04:54:06 EDT
It appears this is a feature which is no longer supported. Since smbfs provides
similar functionality, this report can be closed.
Comment 5 Michael K. Johnson 2002-05-06 18:46:35 EDT
OK, thanks.

Note You need to log in before you can comment on or make changes to this bug.