Bug 365431 - internal audio card not loaded when usb headset plugged in
internal audio card not loaded when usb headset plugged in
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-03 18:43 EDT by Bill Peck
Modified: 2008-04-17 09:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 09:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2007-11-03 18:43:21 EDT
Description of problem:

I'm not sure where to file this bug.  I'm guessing firstboot or anaconda writes
out the modprobe.conf file..

Here is the story..

Boot a Fedora 8 rawhide system with an internal sound card and a USB headset
inserted.  The system will load the USB headset audio but not the internal audio
card.  

/etc/modprobe.conf has the following which prevents it from loading:

options snd-card-0 index=0
options snd-intel8x0 index=0

The funny part is the index=0 was supposed to make the internal sound card load
as the first sound card.  But our USB sound device is already there.

If I comment out the option lines both cards will load from bootup.  And this is
fine since we now rely on pulse audio for determining which sound device to use
and not the order that it was loaded in.

My Suggestion is to remove the code that is generating the index=0 since its not
working anyway.
Comment 1 Jeremy Katz 2007-11-05 10:49:00 EST
On a fresh install, it shouldn't be getting generated as that was getting
generated by system-config-soundcard iirc.  When did you do your install?
Comment 2 Bill Peck 2007-11-06 17:29:28 EST
I just did a fresh install with F-8/GOLD and the following is generated:

options snd-card-0 index=0
options snd-intel8x0 index=0
Comment 3 Antti Huhtala 2007-11-28 02:41:56 EST
(In reply to comment #2)
> I just did a fresh install with F-8/GOLD and the following is generated:
> 
> options snd-card-0 index=0
> options snd-intel8x0 index=0
> 
Yesterday I did a fresh install of F8 and yum-updated it right after. My mobo
soundcard (CK8S) and USB headphones won't play house together. If USB phones are
plugged in at boot they will 'hijack' the snd-card-0 position leaving CK8S out
in the cold.. If I want to hear sound from loudspeakers I can't have USB phones
plugged in at boot time.

In F7 a similar problem was solved by adding a couple of lines to modprobe.conf:

options snd cards_limit=8
...
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7

Now my original (F8-installation) modprobe.conf is (for the sound part):
...
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
alias snd-card-3 snd-mpu401
options snd-card-3 index=3
options snd-mpu401 index=3
...
Note that there is nothing about snd-usb-audio. Nevertheless, if I boot the box
with USB phones plugged in, nothing else will reproduce sound but them.
Now it is not possible to switch between USB headphones and MB soundcard
(loudspeakers) using System->Preferences->Devices(?)->Sound like it was in F7.

I haven't done anything to pulseaudio or alsa files. I've tried various changes
to modprobe.conf (sorry, can't say exactly what) but nothing has solved the
problem so far. I wonder if it is really necessary or wise to have two
definitions for index=0 and index=3?
Comment 4 Martin Stransky 2008-02-22 05:49:05 EST
It's going to be handled by pulseaudio now.
Comment 5 Lennart Poettering 2008-03-28 16:06:53 EDT
Please remove the modprobe.conf fragments that where generated by s-c-s. They
break hotplug.

s-c-s is obsolete.

This is not a PA issue.
Comment 6 Martin Stransky 2008-04-17 09:08:25 EDT
s-c-s has been removed

Note You need to log in before you can comment on or make changes to this bug.