Bug 365691 - Radeon driver locks up machine hard on a regular basis Radeon 9200
Radeon driver locks up machine hard on a regular basis Radeon 9200
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-04 04:21 EST by Dave Russell
Modified: 2009-07-14 12:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 12:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lcpci output (1.61 KB, text/plain)
2007-11-04 04:21 EST, Dave Russell
no flags Details
xorg.conf, note the only change is driver to vesa, to make the machine not crash (566 bytes, text/plain)
2007-11-04 04:23 EST, Dave Russell
no flags Details
xorg log file when using radeon driver (51.65 KB, text/plain)
2007-11-04 04:27 EST, Dave Russell
no flags Details
xorg log when using the vesa driver (58.55 KB, text/plain)
2007-11-04 04:27 EST, Dave Russell
no flags Details
xorg log file when busmode is set to pci (80.03 KB, text/plain)
2007-11-05 04:13 EST, Dave Russell
no flags Details
X.log file of Fedora 10 installation (47.06 KB, text/plain)
2008-12-14 16:18 EST, David Tonhofer
no flags Details
Syslog file of the Fedora 10 installation (36.23 KB, text/plain)
2008-12-14 16:19 EST, David Tonhofer
no flags Details
dmesg output from Amilo 1650G (30.95 KB, text/plain)
2009-04-21 12:23 EDT, info
no flags Details
Xorg.log.0 from after a crash (44.95 KB, text/plain)
2009-04-21 12:33 EDT, info
no flags Details

  None (edit)
Description Dave Russell 2007-11-04 04:21:44 EST
Description of problem:
X starts, and I am able to log in, however anything from 1 minute to a few hours
later, the entire machine locks up hard.

Version-Release number of selected component (if applicable):

How reproducible:
This machine was experiencing the problem in the last month of using F7, however
it had previously been very stable.

Now seeing this under F8 (clean build, not upgrade).

Steps to Reproduce:
1. Install machine
2. Log in
3. Begin working (using menus, surfing net using firefox)
Actual results:
Machine locks up hard

Expected results:
Should be able to use the machine.

Additional info:
I have modified the xorg.conf to use the vesa driver, and so far that has proved
to be stable (I'm writing this bug report on the affected machine).
Comment 1 Dave Russell 2007-11-04 04:21:44 EST
Created attachment 247501 [details]
lcpci output
Comment 2 Dave Russell 2007-11-04 04:23:51 EST
Created attachment 247511 [details]
xorg.conf, note the only change is driver to vesa, to make the machine not crash

Machine doesn't crash with this xorg.conf, if I change the driver back to
radeon, it locks up hard and regularly.
Comment 3 Dave Russell 2007-11-04 04:27:07 EST
Created attachment 247521 [details]
xorg log file when using radeon driver
Comment 4 Dave Russell 2007-11-04 04:27:42 EST
Created attachment 247531 [details]
xorg log when using the vesa driver
Comment 5 Dave Airlie 2007-11-04 09:40:25 EST
can you try adding 

Option "bustype" "PCI"

to your device section or maybe trying some lower AGP speeds..

Via agp chipsets aren't the best..
Comment 6 Dave Russell 2007-11-04 15:14:18 EST
OK, will try that and report back.

One thing to note is that this machine has been stable since very early Fedora
6... and has only just (~4-8 weeks) become unstable in so there's been a change
round that kind of timescale.
Comment 7 Dave Airlie 2007-11-04 16:34:35 EST
I think the newer X driver is possibly trying a higher agp mode, I need a log
from the older stable driver.. and possibly if it was the kernel or X changing
that destabilied..
Comment 8 Dave Russell 2007-11-04 17:06:32 EST
OK, I can get all that information (although not until next week now).

I'll slap a new hdd in and do a vanilla F7 installation.

In the meantime, adding the line below to the device section of the xorg.conf as
you suggested has certainly made it more stable so far, someone else will be
using the machine on and off all week, so I'll be able to report back if it
locks up.

Option "bustype" "PCI"

I obviously also changed the driver back to radeon for this test.

I'll attach the xorg log file with bustype set to PCI just incase that's of
interest too.
Comment 9 Dave Russell 2007-11-05 04:13:43 EST
Created attachment 247801 [details]
xorg log file when busmode is set to pci
Comment 10 Dave Russell 2007-11-05 17:13:31 EST
Hmm, well the machine has locked up once in the last 24 hours... so that's much
improved from it's state when it was first installed with F8, but the issue is
not completely resolved or worked round.

I'll still look at doing a vanilla RC F7 install at the weekend to grab and post
the logs from that.
Comment 11 Bug Zapper 2008-04-04 10:24:23 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 12 David Tonhofer 2008-05-26 05:41:04 EDT
Datapoint: I have Fedora 8 on an Amilo A1650G with an "ATI Radeon XPRESS 200M
5955 (PCIE)" and have had the same trouble at the start of the this year
(machine locks up, preferably when opening a new window). This went away at some
point in time (March?) but now (starting May 22nd or thereabout) it's back. Have
there been any FC8 updates recently which may explain this? Is there a page
tracking the updates rolled out?
Comment 13 David Tonhofer 2008-06-01 11:13:46 EDT
Phenomenon occurs preferably when I'm using the scrllbar in firefox or
thunderbird. Possibly the same as bug #436632
Comment 14 Dave Russell 2008-10-07 23:45:25 EDT
So I've changed the version information to F9...

Things have improved slightly over the time since this was reported. Now, instead of locking the machine hard it just exits X, back to the console... and then re-spawns X dumping the user back at the login screen.

I'll try and get some updated logs etc uploaded over the weekend.
Comment 15 David Tonhofer 2008-12-14 14:59:30 EST
Datapoint: Fedora 10 installation on the Amilo A1650G mentioned 2008-06-26 with an "ATI Radeon XPRESS 200M5955 (PCIE)" reproducibly hangs during graphics ops.

How to reproduce: In the timezone selection screen, move the mouse erratically around until the machine locks up. I had another instance where it hangs while scrlling in another screen.

-- xorg-x11-server 1.5.3-5.fc10
-- New driver is "ati"
Comment 16 David Tonhofer 2008-12-14 16:18:00 EST
Created attachment 326886 [details]
X.log file of Fedora 10 installation

For reference, I attach the X.log file of the Fedora 19 installation which manages to lock up the Amilo
Comment 17 David Tonhofer 2008-12-14 16:19:11 EST
Created attachment 326887 [details]
Syslog file of the Fedora 10 installation 

Additionally, the syslog file of the Fedora 10 installation which locks up the Amilo
Comment 18 David Tonhofer 2008-12-18 07:43:07 EST
Re about the high-probability lock-up during Fedora 10 installation with a Radeon XPRESS 200M (a derivate of Mobility Radeon X300, not a Radeon 9200, sorry), I am happy to report that after successful installation and a "yum update" the machine runs somewhat stabler; lock-up is every 3 hours or so ;-) 

Currently at: xorg-x11-drv-ati-6.9.0-61.fc10.i386
Comment 19 François Cami 2009-02-02 17:33:59 EST
Dave (Russell),
Could you test current F10 ? If that happens, could you post full dmesg and Xorg.0.log as uncompressed attachments ?
Comment 20 Matěj Cepl 2009-03-07 15:30:47 EST
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 21 David Tonhofer 2009-03-09 07:07:01 EDT
Hi. Interested in getting the dmesg/Xorg.0 for the Mobility Radeon X300 under F10?
Comment 22 info 2009-04-21 12:22:06 EDT
Hi, I'm having the same problem, also with a Amilo A1650G. Frequent lockups all through F10, with varying frequency. With the most recent updates it was quite "good", i.e. "only" once or twice a day. I've also used the fglrx driver for a time and had no lockups at all with it (but lots of other issues, so I'm back to the ati driver).

I've now moved to F11 beta, and the lockups are very frequent now (I get max 1 or 2 hours of work, in fact it just froze while I was writing this here, so I had to reboot and start typing again...). Firefox seems particularly bad, but it's not the only culprit, can happen with almost anything, often when scrolling.

This is now:

I attach xorg.log.0 and dmesg from just after a crash.
Comment 23 info 2009-04-21 12:23:01 EDT
Created attachment 340569 [details]
dmesg output from Amilo 1650G
Comment 24 info 2009-04-21 12:29:13 EDT
Oh, and I also tried different settings in the xorg.conf that I found suggested in misc. forum topics:
In the Device section:
Option "AccelMode" "EXA"
Option "BusType" "PCI"

In the Module section:
Disable "dri"
Disable "glx"

I tried this in different combinations, none solved the problem completely, but crashed were less frequent with dri and glx disabled (but X used a lot of CPU then).

BTW, between writing my last comment and now it crashed again...
Comment 25 info 2009-04-21 12:33:19 EDT
Created attachment 340571 [details]
Xorg.log.0 from after a crash
Comment 26 info 2009-04-25 06:32:30 EDT
Hi again, the best combination in my case seems to be:
- nomodeset noapic kernel arguments
- Option "AGPMode" "2" in Xorg.conf
With this, it's been quite stable so far.
Hope this helps
Comment 27 info 2009-05-02 03:32:42 EDT
Forget my last comment - I was probably just lucky for a day, but the problem is not solved and the computer still crashes regularly - everything between a few minutes and two hours after start. Please let me know what I can do to help, test anything or give information or whatever. Thanks
Comment 28 Bug Zapper 2009-06-09 19:09:00 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 29 Bug Zapper 2009-07-14 12:45:18 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.