Bug 365761 - amarok generates Helix returned error : Audio driver error
amarok generates Helix returned error : Audio driver error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 08:04 EST by Adrin Jalali
Modified: 2008-02-19 12:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 12:36:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2007-11-04 08:04:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
I'm using amarok and get it use helix audio driver (RealPlayer) to become able to play various media types. It works fine until its playlist is finished and befire playing another playlist, pidgin plays a sound. After that amarok will not be able to play any media and returns "Helix core returned error : Audio driver error". Restarting the amarok will not fix the problem and the only way I know to play another media is restarting the machine.

/sbin/lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

cat /proc/modules | grep snd
snd_hda_intel 274657 5 - Live 0xf8b1a000
snd_seq_dummy 6725 0 - Live 0xf899f000
snd_seq_oss 29889 0 - Live 0xf8ab8000
snd_seq_midi_event 9793 1 snd_seq_oss, Live 0xf8a77000
snd_seq 44849 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event, Live 0xf8aac000
snd_seq_device 10061 3 snd_seq_dummy,snd_seq_oss,snd_seq, Live 0xf8a73000
snd_pcm_oss 37569 0 - Live 0xf8a92000
snd_mixer_oss 16705 2 snd_pcm_oss, Live 0xf8a6d000
snd_pcm 63685 3 snd_hda_intel,snd_pcm_oss, Live 0xf8a81000
snd_timer 20549 2 snd_seq,snd_pcm, Live 0xf8a52000
snd_page_alloc 11337 2 snd_hda_intel,snd_pcm, Live 0xf8987000
snd_hwdep 10309 1 snd_hda_intel, Live 0xf897f000
snd 43461 16 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep, Live 0xf8a46000
soundcore 9633 2 snd, Live 0xf88bb000


Version-Release number of selected component (if applicable):
amarok-1.4.7-7.fc8

How reproducible:
Always


Steps to Reproduce:
have realplayer installed, use amarok. play a media, stop it, let pidgin plays a media, play another media with amarok.

Actual Results:


Expected Results:


Additional info:
Comment 1 Rex Dieter 2008-02-19 10:02:48 EST
Does Helix/Real work or not like amarok too?  If so, that's where the issue lies.
Comment 2 Adrin Jalali 2008-02-19 10:48:14 EST
I think that was a problem of Helix with pulseaudio. I'm talling this because
now I'm using xine engine, and I've installed package
xine-lib-extras-nonfree-1.1.10.1-1.lvn8
and now I'm able to play types of media I want. Besides having gstreamer makes
life happier. I can not prepare you needed data, cause this bug is reported
about 3 months before ;) and now my system is updated and no such problems occure.

Maybe it's better to close this bug ;)

Best,
adrin.
Comment 3 Rex Dieter 2008-02-19 12:36:03 EST
I was about to suggest using xine, glad you have it working now. :)

Note You need to log in before you can comment on or make changes to this bug.