Bug 36582 - XFree86 4 crashes w/ATI Radeon
XFree86 4 crashes w/ATI Radeon
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 18:31 EDT by Stephen Quam
Modified: 2007-04-18 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 05:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Quam 2001-04-18 18:31:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


XFree86 4.0.3 crashes with the ATI All-In-Wonder Radeon.  This produces a
hard freeze, making it impossible to access the system via the network. The
only way to reboot the system is to use the power switch. 

I have found a fix to this problem, it is due to the installer and
Xconfigurator setting the option in the device section of
/etc/X11/XF86Config-4 to "dri" it should be set to "nodri"



Reproducible: Always
Steps to Reproduce:
1. startx
2.
3.
Comment 1 Alexei Podtelezhnikov 2001-04-19 00:47:02 EDT
I had similar problem. You may want to try to reproduce the hang with lowered 
resolution or color depth. Use 16bpp! That fixed it for me. Would you attach 
XF86Config-4 using the link right below?
Comment 2 Mike A. Harris 2001-04-19 15:36:58 EDT
Radeon does not have DRI support at all, so it isn't a bug in XFree86.
Rather, it is a configuration bug.  Reassigning to Xconfigurator.

(BTW - I use Radeon, Radeon AIW, and Radeon SDR and have not encountered
any problems at depth 24 or 16)
Comment 3 Need Real Name 2001-04-20 07:54:26 EDT
I have an All in Wonder 32MB Radeon. No matter what I config it for (radeon 
generic or all in wonder radeon driver) when Xconfigurator tests the mode the 
keyboard locks and the sreen garbles. When I reboot redhat xdm is set to run 
level 5 so the PC boots and hangs. I need to boot into single user mode to stop 
this. Is there a patch or more specific work around?
Comment 4 vanderkleut 2001-04-25 07:07:21 EDT
I am having the same problem but with multiple machines and different Graph 
cards
1. PI -166 smp with Hercules Stingray (AT3D chipset)
2. K6-2 166 with ET 6000 /4mb
3. laptop P2-266 with Neomagic 128

On all three the Upgrade/install would not run in graphical mode, trying this 
results in a hard crash (only reset button would restore/reboot system) In text 
mode upgrade succeeded on all three (upgraded all three from  RH 7.0 to 7.1) 
but only on the laptop with Neomagic did Xfree86 function after the upgrade,
By the way also config utility xf86cfg in the /usr/X11R6/bin produces a hard 
crash

Greetings Peter
Comment 5 Mike A. Harris 2001-07-23 05:10:25 EDT
To all of you, check your motherboard manufacturer's website for BIOS
flash updates.  There have been some Radeon crash reports that people have
had go away after updating their BIOS on certain buggy Athlon motherboards.

Again, I cannot reproduce these specific crashes on 3 machines I've got
available with 4 different Radeon cards.  I suspect it may be a motherboard
related issue.

For the last poster, please file your bug reports separately after
trying the above advice if it does not solve the problem.
Comment 6 Mike A. Harris 2001-08-13 19:50:09 EDT
No feedback and it WORKSFORME...

Note You need to log in before you can comment on or make changes to this bug.