Bug 36583 - Installer hangs at final stage of boot disk creation
Installer hangs at final stage of boot disk creation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 18:41 EDT by Vic Kaprilian
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 01:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vic Kaprilian 2001-04-18 18:41:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i586)


I believe that RH Linux  7.0 on installation is hanging at the final stage
of boot disk creation due to /dev/fd1 being assigned to the floppy drive
unit.

If skip boot disk creation is selected,  Selecting next  shuts down the
system correctly.

If the create boot disk option is selected, the installation hangs and a
CTRL ALT DEL is required at the end of the install process.

Reproducible: Didn't try, but did try both of the above options.
Comment 1 Brent Fox 2001-04-18 20:18:40 EDT
Do you know why /dev/fd1 is being assigned to floppy?  Are there other devices
on the floppy controller?
Comment 2 Vic Kaprilian 2001-04-18 20:39:54 EDT
No additional devices on floppy controller.

AMI Bios Ver 2.2

Standard CMOS Setup
Floppy A: Not Installed
Floppy B: 1.44MB 3 1/2"

Advanced CMOS Setup
Floppy Drive Swap Enabled
36 Way cable attached to floppy drive on centre connector.
Comment 3 Brent Fox 2001-04-19 23:44:00 EDT
Try setting Floppy A to 1.44MB 3 1/2" and Floppy B to Not Installed.  I think
this might solve the problem.  Also, on your floppy cable, I think the primary
floppy drive needs to be the one on the end of the floppy cable...the end that
has the twist in the ribbon cable.  Try this and see if it helps.
Comment 4 Vic Kaprilian 2001-04-20 01:45:18 EDT
Flawless installation with the floppy drive unit wired as you have suggested 
and also with the changes to CMOS SETUP in effect.

****************************************************************************
I would also like to pass comment that under the previous configuration
that caused the problem with the install process, that /etc/fstab had to be 
manually edited to /dev/fd1 instead of /dev/fd0, to get the floppy drive unit
to work correctly once the operating system was up and running.
****************************************************************************

Note You need to log in before you can comment on or make changes to this bug.