Bug 365881 - mrtg broken with rrdtool-1.3 beta1
mrtg broken with rrdtool-1.3 beta1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mrtg (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 11:35 EST by Fabrice Bellet
Modified: 2008-10-30 16:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 16:18:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2007-11-04 11:35:57 EST
mrtg behave in a strange way when using rrdtool-1.3 beta1:

. first the rrd db file timestamp is not modified, when db is updated by mrtg.
. second problem, db values for a given timestamp are moved to an earlier
timestamp, each time mrtg is run. This /sliding effect/ may be related to the
previous problem, is rrd makes assumptions on the db file timestamp in its
computations.
. and third point, I noticed that new added values in the db are NaN, even with
a newly created db.

downgrading to rrdtool 1.2.23 resolve all these issues.
Comment 1 Jarod Wilson 2007-11-09 11:57:24 EST
Sounds to me like mrtg probably needs to be updated to play nice with rrdtool
1.3. There's a slightly newer mrtg (2.15.2) than in F8 available, but I don't
see anything in its changelog that suggests it adds rrdtool 1.3 compatibility.
Probably need to poke Tobi if that doesn't get things playing nice again.
Comment 2 Jarod Wilson 2007-11-09 11:57:48 EST
Sounds to me like mrtg probably needs to be updated to play nice with rrdtool
1.3. There's a slightly newer mrtg (2.15.2) than in F8 available, but I don't
see anything in its changelog that suggests it adds rrdtool 1.3 compatibility.
Probably need to poke Tobi if that doesn't get things playing nice again.
Comment 3 Fabrice Bellet 2007-11-13 07:09:38 EST
I also tested mrtg-2.15.2, and it has the same problems.
Comment 4 Bug Zapper 2008-04-04 10:24:57 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Vitezslav Crhonek 2008-04-23 05:43:27 EDT
Fabrice, could you please test if the problem is present in F-9 or rawhide?
There's mrtg-2.16.1 version. Or provide me steps to reproduce so I can check it
myself.
Comment 6 Fabrice Bellet 2008-04-23 14:22:57 EDT
Yes, I confirm that the bug is still in rawhide. If needed, I can provide two
consecutive mrtg rrd databases that show the problem.
Comment 7 James J. Moore 2008-05-07 13:35:12 EDT
Experiencing same problem with MRTG and rrdtool 1.3.  Fixed by backing up to 
rrdtool 1.2.23.  
Comment 8 Bug Zapper 2008-05-13 23:50:53 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fabrice Bellet 2008-10-30 16:18:34 EDT
I tested with mrtg-2.16.1-4.fc9.i386 and rrdtool-1.3.4-2.fc9.i386 from testing-updates, and it works fine with this new rrdtool. So I close the bug.

Note You need to log in before you can comment on or make changes to this bug.