Bug 365891 - kernel 2.6.23.1-10 breaks access to usb camera under KDE
kernel 2.6.23.1-10 breaks access to usb camera under KDE
Status: CLOSED DUPLICATE of bug 362221
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 11:46 EST by Joe Christy
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 11:08:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of gphoto2 --debug --auto-detect --summary (443.85 KB, text/plain)
2007-11-16 13:40 EST, Joe Christy
no flags Details
a second run of gphoto --debug ... (212.05 KB, application/octet-stream)
2007-11-17 12:00 EST, Joe Christy
no flags Details

  None (edit)
Description Joe Christy 2007-11-04 11:46:15 EST
Description of problem:
kernel2.6.23.1-10 breaks access to Canon sd110 under KDE

Version-Release number of selected component (if applicable):
2.6.23.1-10 

How reproducible:
every time

Steps to Reproduce:
1.connect camera to USB port while running kde
2.try to access camera
3.experience frustration
  
Actual results:
abject failure

Expected results:
access to camera's memory either through digikam, or as a USB storage device

Additional info:
When I connect this camera I get a KDE panel asking if I want to (1) open it in
a new window, (2) digikam detect and download, or (3) do nothing.

Under earlier kernels, I could access the photos on the camera by any of these
three routes. In case (1) digikam launches and throws up a window for the
camera; it then puts up a panel telling me that it cannot access the camera,  to
check that it is turned on and properly connected, and asks if I want to retry
or abort. Choosing retry the connection succeeds and the digikam camera window
show me the photos on the camera. In case (2), a new konqueror window appears
and presents me with a list of the photos on the camera. In case (3), I launch
digikam, open the camera from the camera menu, and proceed as in case (1).

Under kernel 2.6.23.1-10, in cases (1) and (3), digikam fails fails and throws
up the warning panel ad infinitum, as long as I press retry. Pressing abort and
starting a new from the camera menu behaves identically. In case (2), the
konqueror window opens, but informs me that it cannot access the device.

With earlier kernels, in cases (1) and (3) lsof shows a single digikam process
accessing the usb device in question, and no instances of kio_kamera are
running. With kernel 2.6.23.1-10, a dozen or so instances of kio_kamera process
are launched  in any of the three cases, and in cases (1) and (3), lsof shows
them contending amongst themselves and with 2 or 3 digikam process for the USB
device.
Comment 1 Paul Jenner 2007-11-15 14:12:37 EST
This may be a duplicate of bug #362221.

Can you try to run "gphoto2 --debug --auto-detect --summary" and see if the
error matches?
Comment 2 Joe Christy 2007-11-16 13:40:35 EST
Created attachment 261621 [details]
Output of gphoto2 --debug --auto-detect --summary

Output of gphoto2 --debug --auto-detect --summary on Linux moby.eshu.net
2.6.23.1-49.fc8 #1 SMP Thu Nov 8 22:14:09 EST 2007 x86_64 x86_64 x86_64
GNU/Linux
Comment 3 Joe Christy 2007-11-17 11:57:42 EST
As you see above, the problem persists to the latest F8 kernel. Since it's
absolutely essential to me that I be able to download photos from my camera and
upload them onto the net, I've kept my laptop w/ F7 where I have access to a
working configuration with a 2.6.22 kernel.

However, when I do boot into the 2.6.23.1-10 kernel, running gphotoq ... reveals
the following:
Comment 4 Joe Christy 2007-11-17 12:00:41 EST
Created attachment 262411 [details]
a second run of gphoto --debug ...

gphoto2 --debug --auto-detect --summary output under Linux pequod.eshu.net
2.6.23.1-10.jpc1 #1 SMP Wed Oct 31 13:15:20 PDT 2007 i686 i686 i386 GNU/Linux
Comment 5 Paul Jenner 2007-11-21 14:25:14 EST
If this is F8, can you bump the version on the bug report which is still F7?

From the gphoto output, this does look like a duplicate of bug #362221 but I
assume both should be left open to track different Fedora releases - one F7 and
the other F8.
Comment 6 Chuck Ebbert 2007-11-26 11:08:37 EST

*** This bug has been marked as a duplicate of 362221 ***

Note You need to log in before you can comment on or make changes to this bug.