Bug 365911 - Sun's Java crashes due to assertions in libxcb
Sun's Java crashes due to assertions in libxcb
Status: CLOSED DUPLICATE of bug 301691
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 12:09 EST by Anton Keks
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 04:15:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Keks 2007-11-04 12:09:10 EST
Description of problem:
Not able to use Java GUI programs with Sun's JDK

Version-Release number of selected component (if applicable):
Sun's Java 1.5 or 1.6
libxcb-1.0-3.fc8
libX11-1.1.3-4.fc8

How reproducible:
Always

Steps to Reproduce:
1. Run any GUI Java application (that uses Swing/AWT)
2. It will not start and print:
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted
 
IcedTea seems not to have this problem, but it cannot be used with all Java
applications, and Java developers need to have several older versions of the JDK
installed.

The bug is registered at Sun:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

However, older versions are unlikely to be fixed and therefore will not work
with Fedora.

There is a proposal to remove the problematic assertion from libxcb:
http://developer.momonga-linux.org/viewvc/trunk/pkgs/libxcb/libxcb-0.9.93-xcb_xlib_no_assert.patch

According to Google search, it is causing problems with other software as well,
not only Java.

It probably would be a good idea to apply a similar patch to libxcb shipped with
Fedora.
Comment 1 Karl Misselt 2007-11-06 00:54:56 EST
Seen also with icedtea: 

java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8
libxcb-1.0-3.fc8
java-1.5.0-gcj-1.5.0.0-17.fc8
libX11-1.1.3-4.fc8

[:] ./spot
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Abort

Spot is java gui code for astronomical observing planning. Works under 
Fedora 7.

 
Comment 2 Petr Tuma 2007-11-06 02:52:21 EST
Duplicate of java-xcb-lock bug (301691) ?
Comment 3 Anton Keks 2007-11-06 04:15:20 EST

*** This bug has been marked as a duplicate of 301691 ***

Note You need to log in before you can comment on or make changes to this bug.