Bug 36597 - updatedb memory eating bug
updatedb memory eating bug
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: slocate (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 20:23 EDT by Joshua West
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 21:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua West 2001-04-18 20:23:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)


It seems that when running updatedb (as root, of course), major amounts of
memory are consumed, and not freed once the database update is complete. 
My system has 256mb of RAM - about 205mb free on initial X login.  As I run
updatedb, I watch the memory slowly get eaten to about 110mb free.  When
updatedb is completed, it does not free all of that memory.

Reproducible: Always
Steps to Reproduce:
1. Login as root
2. Update the slocate database by issuing the command 'updatedb'
3. Watch memory
	

Actual Results:  Memory is eaten

Expected Results:  Memory should be freed once the application has
completed the update.

Redhat Linux 7.1
Dual Pentium-III 800mhz Processors
256mb RAM
Comment 1 Bill Nottingham 2001-04-18 21:26:30 EDT
It's being used by the kernel for cache. If you'll note the memory
statistics, the increase will pretty much all be in the 'buffers'
or 'cached' category.

Comment 2 Joshua West 2001-04-19 00:13:13 EDT
Once it is finished then, is there a way to free up the buffers & cached
sections of memory since this wouldn't be in use?
Comment 3 Bill Nottingham 2001-04-19 00:16:37 EDT
No; the kernel will clear out the cache if it needs it for other
programs.

Note You need to log in before you can comment on or make changes to this bug.