Bug 365981 - Missing python bindings for clutter-gst and clutter-gtk
Missing python bindings for clutter-gst and clutter-gtk
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pyclutter (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Allisson Azevedo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 14:04 EST by Daniel Berrange
Modified: 2007-12-28 12:22 EST (History)
0 users

See Also:
Fixed In Version: 0.4.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-28 12:19:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated RPM spec file which adds sub-RPms for GTK + GST clutter bindings (3.43 KB, text/plain)
2007-11-04 14:04 EST, Daniel Berrange
no flags Details

  None (edit)
Description Daniel Berrange 2007-11-04 14:04:56 EST
Description of problem:
The pyclutter RPM is missing the bindings for the clutter-gst and clutter-gtk
packages because the BuildRequire lines are incomplete. Further, to avoid
forcing install of clutter-gtk RPM, when only the clutter python binding is
wanted, there should be sub-RPMs for the GST & GTK bindings.

Finally, to comply with Fedora packaging guidelines the RPM should explicitly
all directories it creates, rather than simply using a wildcard in the %files
section.

Version-Release number of selected component (if applicable):
pyclutter-0.4.2-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. Look for  pyclutter-gtk  RPM
2.
3.
  
Actual results:
None found

Expected results:


Additional info:
Comment 1 Daniel Berrange 2007-11-04 14:04:56 EST
Created attachment 247641 [details]
Updated RPM spec file which adds sub-RPms for GTK + GST clutter bindings
Comment 2 Daniel Berrange 2007-12-13 20:24:52 EST
If you don't have time to apply these fixes to pyclutter in Fedora, I will
happily apply them myself - I'm already a Fedora maintainer of many packages, so
its not a problem ?
Comment 3 Allisson Azevedo 2007-12-14 20:29:05 EST
Hi Daniel,

First: i'm sorry for this big late in response.

Second: yes, you can apply the patches, thanks for help.

Third: you would act as co-maintainer of this, and others clutter packages?
Comment 4 Fedora Update System 2007-12-20 14:48:55 EST
pyclutter-0.4.2-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pyclutter'
Comment 5 Fedora Update System 2007-12-28 12:19:24 EST
pyclutter-0.4.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Daniel Berrange 2007-12-28 12:22:10 EST
Wrt to comment #3, while I'm happy to do ad-hoc bug fixes as & when I find them,
I don't really have the spare time to be an official co-maintainer of the
clutter packages.

Note You need to log in before you can comment on or make changes to this bug.