Bug 366041 - anaconda manual partition weridness
anaconda manual partition weridness
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 14:35 EST by Valent Turkovic
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 10:52:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2007-11-04 14:35:29 EST
Description of problem:
In manual partition mode anaconda randomly (at least it look that way to me)
sorts partitions.

I can't manually partition a hard disk with anaconda and make partition in some
particular order; ie. I want 
/sda1 with 8GB
/sda2 (swap) - 3GB
/sda3 - 20gb
/sda4 - extended 
/sda5- 8GB
/sda6 - 10GB
/sda7 - 8GB
/sda8 - 40GB

but anaconda randomly reorganizes and mixes the order or partitions!

Version-Release number of selected component (if applicable):


How reproducible:
I tested it with Fedora 8 test 3 and Fedora 8 RC3 on two systems (not in Virtal
Machines)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
I expect that each new added partition goes on the end of existing stack of
partitions, not on some random place!

Additional info:
If you need more feedback just tell me.
Comment 1 Jeremy Katz 2007-11-05 10:52:55 EST
The ordering is based on the size as well as what the mountpoint is.  This is
needed so that you can have multiple partitions set to "grow" and maximizing the
space used for each.
Comment 2 Valent Turkovic 2007-11-05 14:24:34 EST
How can anaconda know what each partition is, if eachone has same filetype, ie.
ext3. This makes no sense to me, especially because it is called "manual
partitioning". I wan't to make my own partition scheme, and not that it gets
reorganized in a way that it doesn't make sense to me.

This should be called "assisted partitioning" and there should be a real "manual
partition" mode.

Note You need to log in before you can comment on or make changes to this bug.