Bug 366091 - Bug in alsa 1.0.14 breaks jackplug
Bug in alsa 1.0.14 breaks jackplug
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 15:07 EST by Matt Hirsch
Modified: 2008-02-25 10:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 10:06:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Hirsch 2007-11-04 15:07:00 EST
Description of problem: The alsa jackplug no longer works. It worked in previous
fedora versions of alsa, but I can't give a version number.

When the jackplug is configured as:

pcm.jackplug {
        type plug
        slave { pcm "jack" }
}

pcm.jack {
        type jack
        playback_ports {
               0 alsa_pcm:playback_1
               1 alsa_pcm:playback_2
        }
               capture_ports {
               0 alsa_pcm:capture_1
               1 alsa_pcm:capture_2
        }
}


And tested with aplay:

aplay -Djackplug /usr/share/sounds/purple/receive.wav

The following error is produced:

aplay: set_params:900: Sample format non available


Version-Release number of selected component (if applicable): alsa-lib-1.0.14-3.fc7


How reproducible: always


Steps to Reproduce:
1. Configure jackplug in .asoundrc as above
2. Test using aplay -Djackplug <some .wav file>
  
Actual results:
aplay produces the following error message:
aplay: set_params:900: Sample format non available

Expected results:
aplay should route sound into the jack audio connection kit.

Additional info:
This is an alsa configure script bug and has been described here:
https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/148510
http://hg-mirror.alsa-project.org/alsa-lib/rev/917d1281c93f
Comment 1 Martin Stransky 2008-02-25 10:06:50 EST
Please report it to ALSA project (www.alsa-project.org). Seems to be related to
sound config for your sound card where some plugins are missing (probably the
rate plugin?)

Note You need to log in before you can comment on or make changes to this bug.