Bug 36620 - dhcpd starts without error, but does nothing at all after that
dhcpd starts without error, but does nothing at all after that
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 02:09 EDT by Jordan Russell
Modified: 2007-04-18 12:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 13:55:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2001-04-19 02:09:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


"The program simply will not work." -- really, in this case!

# /usr/sbin/dhcpd -d -f eth0
Internet Software Consortium DHCP Server 2.0pl5
Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.
All rights reserved.

Please contribute if you find this software useful.
For info, please visit http://www.isc.org/dhcp-contrib.html

Listening on Socket/eth0/10.70.77.0
Sending on   Socket/eth0/10.70.77.0

... and nothing after that. Absolutely no DHCP requests are responded to. 
No error messages, nothing.

When I downgrade to the dhcp-2.0-12.i386.rpm that came with RedHat 7.0, 
dhcpd works fine.

However, the "old" dhcpd says this instead at startup:

Listening on LPF/eth0/00:60:08:ac:91:d2/10.70.77.0
Sending on   LPF/eth0/00:60:08:ac:91:d2/10.70.77.0
Sending on   Socket/fallback/fallback-net

LPF stands for "linux packet filter." And the new dhcpd is not using it. 
That seems to be the likely explanation why it isn't working.

I am running kernel 2.2.19 instead of the 2.4 kernel that comes standard 
with Red Hat 7.1. But that shouldn't matter, should it? dhcpd contains no 
2.4-specific stuff as far as I can tell. (?)

Reproducible: Always
Steps to Reproduce:
n/a
Comment 1 Jordan Russell 2001-04-19 15:01:46 EDT
After investigating further, I found the problem wasn't related to the kernel 
version, but rather due to my ipchains firewall not letting packets addressed 
to 255.255.255.255 through.

But, I don't believe I should have had to change my firewall settings. Why is 
dhcp-2.0pl5 built to use "socket" instead of "LPF" (Linux Packet Filter) as 
before? From what I understand, "socket" is only meant to be used with 2.0.x 
kernels. So this looks like a "configure" error to me.
Comment 2 vigna 2001-05-04 03:41:44 EDT
Same problem here. I have three network interfaces (eth0, eth1, eth2). The last
one is wireless. dhcpd worked fine until I upgraded to 7.1. Then it stopped
working on the wireless interface. Request packets were arriving (I checked with
tcpdump) but no answer was given, even with the firewall down. Downgrading
solved the problem. 

The startup message of the new (non working) version is 

May  4 09:27:12 dina dhcpd: Listening on Socket/eth2/192.168.0.128
May  4 09:27:12 dina dhcpd: Sending on   Socket/eth2/192.168.0.128
May  4 09:27:12 dina dhcpd: Listening on Socket/eth1/10.0.0.0
May  4 09:27:12 dina dhcpd: Sending on   Socket/eth1/10.0.0.0
May  4 09:27:12 dina dhcpd: Listening on Socket/eth0/192.168.0.0
May  4 09:27:12 dina dhcpd: Sending on   Socket/eth0/192.168.0.0
May  4 09:27:12 dina dhcpd: Listening on Socket/eth2/192.168.0.128
May  4 09:27:12 dina dhcpd: Sending on   Socket/eth2/192.168.0.128
May  4 09:27:12 dina dhcpd: Listening on Socket/eth1/10.0.0.0
May  4 09:27:12 dina dhcpd: Sending on   Socket/eth1/10.0.0.0
May  4 09:27:12 dina dhcpd: Listening on Socket/eth0/192.168.0.0
May  4 09:27:12 dina dhcpd: Sending on   Socket/eth0/192.168.0.0
May  4 09:27:12 dina dhcpd: dhcpd startup succeeded

The old one:


May  4 09:40:55 dina dhcpd: Listening on LPF/eth2/00:40:05:de:c8:5c/192.168.0.128
May  4 09:40:55 dina dhcpd: Sending on   LPF/eth2/00:40:05:de:c8:5c/192.168.0.128
May  4 09:40:55 dina dhcpd: Listening on LPF/eth1/00:60:08:ab:c3:9a/10.0.0.0
May  4 09:40:55 dina dhcpd: Sending on   LPF/eth1/00:60:08:ab:c3:9a/10.0.0.0
May  4 09:40:55 dina dhcpd: Listening on LPF/eth0/00:01:02:f3:58:ab/192.168.0.0
May  4 09:40:55 dina dhcpd: Sending on   LPF/eth0/00:01:02:f3:58:ab/192.168.0.0
May  4 09:40:55 dina dhcpd: Sending on   Socket/fallback/fallback-net
May  4 09:40:55 dina dhcpd: Listening on LPF/eth2/00:40:05:de:c8:5c/192.168.0.128
May  4 09:40:55 dina dhcpd: Sending on   LPF/eth2/00:40:05:de:c8:5c/192.168.0.128
May  4 09:40:55 dina dhcpd: Listening on LPF/eth1/00:60:08:ab:c3:9a/10.0.0.0
May  4 09:40:55 dina dhcpd: Sending on   LPF/eth1/00:60:08:ab:c3:9a/10.0.0.0
May  4 09:40:55 dina dhcpd: Listening on LPF/eth0/00:01:02:f3:58:ab/192.168.0.0
May  4 09:40:55 dina dhcpd: Sending on   LPF/eth0/00:01:02:f3:58:ab/192.168.0.0
May  4 09:40:55 dina dhcpd: Sending on   Socket/fallback/fallback-net
May  4 09:40:55 dina dhcpd: dhcpd startup succeeded

Comment 3 Need Real Name 2001-05-29 06:53:33 EDT
I came across the problem also if you download the source for the version 
2.0pl5 from www.isc.org and compile this it also works, this seems to be a 
problem the the rpm in which it is distributed.
Comment 4 Miguel Freitas 2001-08-30 11:47:34 EDT
I had the same problem with a fresh RedHat 7.1 installation. 
No firewall configured. The tcpdump shows all dhcp requests and no
responses.

After a whole afternoon trying to make it work I gave up and downgraded
to dhcp-2.0-12.i386.rpm (this version is fine).
BTW, I tried the last dhcp from rawhide and it doesn't work too.

It's amazing that a serious issue like this, opened at April did not get
any redhat response till today. Where's redhat QA?
Comment 5 Elliot Lee 2001-09-11 18:14:41 EDT
Apologies for the unresponsiveness of the previous dhcp packager...
Unfortunately I'm not able to reproduce the problem, and the report is sort of
suspect because of the original firewall thing (it's entirely reasonable to
expect people to fix previously undiscovered bugs in their firewalls...)

Ideas anyone?
Comment 6 Miguel Freitas 2001-09-12 12:54:13 EDT
It's hard to believe you couldn't reproduce, because I couldn't make it work!
Not even once! :)

My guess is about LPF x Socket. I haven't try downloading the
source but there must be a compiling option somewhere 
(like configure --without-xxxx?) to choose the method it use
for listening. 

Isn't possible to turn back to the old LPF method?
Comment 7 Elliot Lee 2001-09-12 13:06:46 EDT
If you look at the spec file and source tree, you will see there is no
configuration to be changed...
Comment 8 Jordan Russell 2001-09-12 13:22:17 EDT
If I download ftp://ftp.isc.org/isc/dhcp/dhcp-2.0pl5.tar.gz and compile it 
using the defaults, I get a dhcpd binary that uses LPF.
Comment 9 Elliot Lee 2001-09-12 13:37:38 EDT
Why is LPF "wrong", what other options are available, and how are they selected?

Also, if you aren't using the 2.4 kernel, that could explain the problems,
"don't do that". In low-level programs there are sometimes compile time options
that depend on knowing which kernel is targetted.

Some ideas, anyways...
Comment 10 Jordan Russell 2001-09-12 13:51:37 EDT
An "LPF" binary is produced when I compile dhcp-2.0pl5.tar.gz with the 
defaults, on *either* a 2.2.19 or 2.4.2 system.

Now having said that, I think I see the bug now with the RPM. Try building the 
source RPM and watch closely. You'll notice:

"-DLINUX_MAJOR=MajorVersion -DLINUX_MINOR=MinorVersion"

Using valid numbers there would help :)
Comment 11 keithu@parl.clemson.edu 2001-09-24 16:27:26 EDT
I have the exact same problem.  Use the RH 7.1 package and it just doesn't
work.  No firewall.  tcpdump shows requests arriving, but no responses. 
Requests are arriving on / should be going out eth1.  Downgrading to the
packages that shipped with RH 7.0 worked, but doesn't allow me to constrain the
IP assigned based on the ethernet address.
Comment 12 Elliot Lee 2001-12-26 15:21:33 EST
Hi,

I recently built dhcp-3.0 into rawhide - I am betting this problem is fixed by
it. Feel free to reopen the bug if not.
Comment 13 Jordan Russell 2002-03-25 13:54:59 EST
dhcp-3.0 seems to be gone from rawhide, apparently replaced with the old, 
broken dhcp-2.0pl5-8 package.

So, reopening...
Comment 14 Elliot Lee 2002-03-25 14:07:09 EST
That's the, uh, other rawhide.

The 3.0 package isn't gone, just deferred from the current line of development
due to compatibility concerns. It will reappear eventually, trust me.


Note You need to log in before you can comment on or make changes to this bug.