Bug 366231 - system-config-firewall GUI does not work, TUI cannot be customized
system-config-firewall GUI does not work, TUI cannot be customized
Status: CLOSED DUPLICATE of bug 331671
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 18:36 EST by Michel Alexandre Salim
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 07:05:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iptables/s-c-f configuration files (30.00 KB, application/octet-stream)
2007-11-05 10:00 EST, Michel Alexandre Salim
no flags Details

  None (edit)
Description Michel Alexandre Salim 2007-11-04 18:36:48 EST
Description of problem:
The GUI client would freeze and take up 100% CPU without even displaying any
text (just the window frame). The TUI would display the current configuration,
but once you save any changes it erases any custom port settings.

Version-Release number of selected component (if applicable):
system-config-firewall-1.0.8-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-firewall 
2. Run 'sudo system-config-firewall-tui'
3. Add a custom port

Actual results:
(1) launches s-c-f which then freezes, taking 100% CPU. (2) would work but (3)
would cause any existing custom port configuration to be erased.

Expected results:
All should work as expected (worked right after F8t2 was released)

Additional info:
I tried deleting /etc/sysconfig/system-config-firewall and it did not have any
effect.
Comment 1 Thomas Woerner 2007-11-05 08:17:14 EST
Please make a tar archive which contains

/etc/*/ip*tables*
/etc/sysconfig/system-config-{firewall,securitylevel}

and attach it to this bugzilla.

Please also attach the output of

ls -Z /etc/*/ip*tables* /etc/sysconfig/system-config-{firewall,securitylevel}
Comment 2 Michel Alexandre Salim 2007-11-05 10:00:29 EST
Created attachment 248221 [details]
iptables/s-c-f configuration files
Comment 3 Michel Alexandre Salim 2007-11-05 10:02:43 EST
Files attached
Comment 4 Thomas Woerner 2007-11-08 07:05:40 EST

*** This bug has been marked as a duplicate of 331671 ***

Note You need to log in before you can comment on or make changes to this bug.