Bug 366481 - check-buildroot: xargs: grep: Argument list too long
check-buildroot: xargs: grep: Argument list too long
Status: CLOSED DUPLICATE of bug 275321
Product: Fedora
Classification: Fedora
Component: findutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 04:05 EST by Mamoru TASAKA
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 03:18:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2007-11-05 04:05:59 EST
Description of problem:

I don't know the impact of this issue, however
when I compile xscreensaver (I maintain xscreensaver), 
check-buildroot complains about:
---------------------------------------------------------
extracting debug info from
/home/tasaka1/rpmbuild/INSTROOT/xscreensaver-5.03-14.fc8-root-tasaka1/usr/libexec/xscreensaver/cubenetic
extracting debug info from
/home/tasaka1/rpmbuild/INSTROOT/xscreensaver-5.03-14.fc8-root-tasaka1/usr/libexec/xscreensaver/sonar
23578 blocks
+ /usr/lib/rpm/check-buildroot
xargs: grep: Argument list too long
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
---------------------------------------------------------

Version-Release number of selected component (if applicable):
xscreensaver-5.03-14.fc8 (srpm)
rpm-build-4.4.2.2-4.fc8
findutils-4.2.31-2.fc8

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild --rebuild xscreensaver-5.03-14.fc8.src.rpm
  
Actual results:
See above

Additional info:
I think something changed outside of rpm...
Comment 1 Panu Matilainen 2007-11-05 05:17:34 EST
xargs, not rpm, is giving grep too much to process at once. Reassigning to
findutils.
Comment 2 Vitezslav Crhonek 2007-11-07 03:18:37 EST

*** This bug has been marked as a duplicate of 275321 ***

Note You need to log in before you can comment on or make changes to this bug.