Bug 36657 - rpm --rebuild of kernel-2.4.2-2.src.rpm fails
Summary: rpm --rebuild of kernel-2.4.2-2.src.rpm fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-19 14:10 UTC by John Jasen
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-19 18:37:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Jasen 2001-04-19 14:10:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.4-pre1 i686)


there appears to be a patch conflict in the .src.rpm, namely between the
linux-2.4.2-parport.patch drivers/parport/Changelog and something else (the
-ac3 patch?)

Reproducible: Always
Steps to Reproduce:
1.rpm --rebuild/path/to/kernel-2.4.2-2.src.rpm
2.
3.
	

Actual Results:  Patch #204 (linux-2.4.2-toshoboe.patch):
+ patch -p1 -s
+ echo Patch #205 (linux-2.4.2-parport.patch):
Patch #205 (linux-2.4.2-parport.patch):
+ patch -p1 -s
The next patch would create the file `drivers/parport/ChangeLog',
which already exists!  Assume -R? [n] n
Apply anyway? [n] n
1 out of 1 hunk ignored -- saving rejects to drivers/parport/ChangeLog.rej
error: Bad exit status from /var/tmp/rpm-tmp.62855 (%prep)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.62855 (%prep)

Expected Results:  expected it to possibly die during the compile; not
during the patching; or maybe even make kernel .rpms.

Comment 1 John Jasen 2001-04-19 14:39:15 UTC
Patch #261 (linux-2.4.2-restorestate.patch):
+ patch -p1 -s
The next patch would create the file `drivers/parport/ChangeLog',
which already exists!  Assume -R? [n] n
Apply anyway? [n] n
1 out of 1 hunk ignored -- saving rejects to drivers/parport/ChangeLog.rej
error: Bad exit status from /var/tmp/rpm-tmp.25326 (%prep)

Comment 2 John Jasen 2001-04-19 14:41:10 UTC
that was after commenting out patch205 in the kernel-2.4.spec file

Comment 3 Arjan van de Ven 2001-04-19 14:44:45 UTC
This is strange. We build the "final" RPM's by doing a rpm --rebuild on the
src.rpm.

What system are you trying this on?

Comment 4 John Jasen 2001-04-19 14:49:51 UTC
Redhat 6.2, latest updates + a few extras (2.4.4-pre kernel, XFree86 installed
from a rebuilt 7.0 src.rpm, kde2 from .rpms). So far, it looks like on x86,
there are two patches that fail on the drivers/parport/Changelog -- after the
patches are commented out, it starts building the .rpms as expected.

None of the changes to my system should effect patch, I would think?

Comment 5 John Jasen 2001-04-19 15:04:40 UTC
I also got this on building for 686smp:

* Kernel hacking
*
Memory mapped I/O debugging (CONFIG_DEBUG_IOVIRT) [Y/n/?]
Magic SysRq key (CONFIG_MAGIC_SYSRQ) [Y/n/?]
 
*** End of Linux kernel configuration.
*** Check the top-level Makefile for additional configuration.
*** Next, you must run 'make dep'.
 
The following defaults are missing:
  DECnet: router support (EXPERIMENTAL) (CONFIG_DECNET_ROUTER) [N/y/?]
make: *** [oldconfig_nonint] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.38096 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.38096 (%build)

Comment 6 Arjan van de Ven 2001-04-19 16:11:49 UTC
you might have an older version of the "patch" program which doesn't understand
how to delete files.

The decnet one is strange, as the i686-smp config file has
CONFIG_DECNET_ROUTER=y
in it. Maybe you need to also upgrade your bash.
Oh and 2.4 kernels are NOT supported on 6.2 because you need a LOT of other
packages as well:
* new kudzu
* hotplug
* ext2progs
* ppp

and if you want 3D accel also a new X server.


Comment 7 John Jasen 2001-04-19 16:20:23 UTC
Yeah, I'm aware of the dependencies of the 2.4.x kernel. I'm not stressed about
kudzu or ppp at the moment.

downloading src.rpms for patch and bash as we speak.

Comment 8 John Jasen 2001-04-19 18:37:52 UTC
patch and bash upgrades seem to have done the trick.

This thing is getting to be a _long_ way from a 6.2 base install. :)

Comment 9 Arjan van de Ven 2001-04-19 20:17:58 UTC
Sounds like this is fixed then.
I'm closing as "NOTABUG" as it, well, isn't really.
If you have further problems, please reopen this bug or open a new 
one if it is too unrelated to this one.


Note You need to log in before you can comment on or make changes to this bug.