Bug 36665 - Installer does not detect winbook XL touchpad
Installer does not detect winbook XL touchpad
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 11:20 EDT by William Mulvihill
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 17:44:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Mulvihill 2001-04-19 11:20:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.1b1; Mac_PowerPC)


When I tried to install RH 7.1 from CD on a WinbookXL, it does not 
detect the touchpad mouse.  I have had RH7.0 running on this 
system for a long time with no problems concerning the mouse.  
Basically, the installers starts, tries to "Probe for mouse type", comes 
up with a dialog saying it could not automatically find the mouse, then 
it asks me to pick a mouse.  I have tried Generic Mouse types and 
Microsoft compatible mice with no luck.  When I try different types, 
one of three things happen, 1. the Xserver in the installer fails to start 
and the computer reboots, 2. the Xserver starts but crashes right 
away, or 3. (most common) ths Xserver starts but I can't move the 
mouse.  Now I did go ahead and try to to a text mode install and 
everything went fine from there except when the computer restarted 
after the install.  X windows loaded and I couldn't move the mouse 
(no surprise).  

Reproducible: Always
Steps to Reproduce:
1.  Get a Winbook XL with a touchpad (or maybe any old laptop?)
2.  Run the installation of RH 7.1 from a CD. 
3.  Boom, the probing for mouse type should fail and then you will be 
prompted to select a mouse type.  I tried many with no effect.  

	

Actual Results:  The mouse pointed won't move on the screen.  

Expected Results:  The mouse pointer should have moved!

Again, this was not a problem with RH7.0.  You should also know 
that when I did install RH 7.1 (via text-mode) I did select upgrade 
instead of just wiping the HD.
Comment 1 Brent Fox 2001-04-19 16:49:30 EDT
Sounds like a kudzu problem since it can't detect the mouse.  Changing component.
Comment 2 Bill Nottingham 2001-04-19 16:55:33 EDT
What is the mouse normally configured as?
Comment 3 William Mulvihill 2001-04-20 08:55:45 EDT
I used the RH7.0 CD to see what it had probed the mouse type as 
originally.  It shows up as generic 3-button PS/2 type.  When I select this 
type with the RH 7.1 CD, it, again, starts the X server fine but the mouse 
doesn't move.  I know its not hardware because the RH 7.0 CD let me 
move the mouse after it autodetected Generic 3-Button PS/2.
Comment 4 Bill Nottingham 2001-04-23 23:25:46 EDT
Can you rebuild kudzu with -DDEBUG_PS2_PROBE=1 and post the output of
kudzu -p -b psaux
?
Comment 5 William Mulvihill 2001-06-26 13:15:21 EDT
Sorry for the slow response.  I had to revert the system to RH 7.0.  After
getting that all situated (downloading updates, configuring stuff, etc.), I
downloaded the src rpm for kudzu-0.98.10 which is the version that comes with RH
7.1.  I compiled the source for it and ran it from command line (mind you, I'm
in RH 7.0 with the mouse working right now):
[root@phobos kudzu-0.98.10]# ./kudzu -p -b psaux
mouse_cmd: 244
mouse enable failed: no mouse?
mouse_cmd: 242
mouse type command failed: no mouse
resetting mouse
mouse_cmd: 244
mouse enable failed: no mouse?
mouse_cmd: 242
mouse type command failed: no mouse
initial mouse type check strange: no mouse
[root@phobos kudzu-0.98.10]# 

The version of kudzu now currently installed on this RH 7.0 installation is
0.72.  Should I provide a diff between the two psaux.c files in each version?
Comment 6 William Mulvihill 2001-08-07 10:58:44 EDT
Having noticed the new beta, I thought to download the latest kudzu 0.99-10 src
rpm and try it just to make sure I'll be able to use RedHat 7.2 on this
Winbook.  Unfortunately, this is the output of ./kudzu -b -p psaux able enabling
DEBUG_PS2_PROBE:
[root@phobos kudzu-0.99.10]# ./kudzu -p -b psaux
mouse_cmd: 244
mouse enable failed: no mouse?
mouse_cmd: 242
mouse type command failed: no mouse
resetting mouse
mouse_cmd: 244
mouse enable failed: no mouse?
mouse_cmd: 242
mouse type command failed: no mouse
initial mouse type check strange: no mouse
[root@phobos kudzu-0.99.10]# 

Please Please Please let me know what I can do to help out fixing this bug.  I'd
like to upgrade when RH 7.2 comes out.  

PS.  Should I be running this kudzu command from a console or will any terminal
(including one in X-windows) do?
Comment 7 William Mulvihill 2001-08-07 13:46:12 EDT
With even more investigation I've found that by booting into single-user I was
able to run kudzu version 0.99-10 and receive the following final output:
-
class: MOUSE
bus: PSAUX
detached: 0
device: psaux
driver: genericps/2
desc: "Generic Mouse (PS/2)"

Then I tried to run 0.98-10 and it seemed to give me the same debugging stuff as
0.99 but with no final output. like the stuff above  Now this very well could
have been because I had already "configured" the mouse with version 0.99-10. 
But once I left single user mode (which immediately entered me into runlevel 5),
my mouse is working.  Now of course, the original kudzu might have been run
after I exited single-user, but I thought I'd include that.

There doesn't seem to be much difference between the psaux.c between 0.98 and
0.99.  In fact, here is the diff:
[root@phobos SOURCES]# diff kudzu-0.99.10/psaux.c kudzu-0.98.10/psaux.c
103a103,105
> 	int mouseid = 0;
> 	char buf[256];
> 	unsigned char ch;
[root@phobos SOURCES]#    

I don't see how these small changes could make it work.  But let me know if you
think it is fixed (of course, realize that I'll be getting RH 7.2 when it comes
out and "letting you know" if it still doesn't work ;) No, really, I do
appreciate your attention to this.)  Thanks!
Comment 8 Bill Nottingham 2001-08-07 16:11:17 EDT
Yes, currently running the mouse probe while either X or gpm is running won't
work; if kudzu finds it when neither are running, I'm going to assume that it is
working now.
Comment 9 William Mulvihill 2001-08-08 14:22:14 EDT
I went into single-user mode again to try 0.98-10 just for my own purposes and
found that it also will detect the mouse on its own.  So I'm starting to suspect
that it isn't even kudzu that has a problem with the mouse.  What is the chain
of events when installing?  Like...what gets called, and then calls this and
that and that and then finally calls kudzu?  Maybe its the previous step.  I'll
leave it up to you to reopen or reclassify this bug.  I suppose my next step
should be to download the isos of the roswell beta and try to update my
installation.  I'll let you know the results of that.  Thanks!
Comment 10 William Mulvihill 2001-08-09 14:56:08 EDT
I'm reopening this bug because I've discovered that the bug is not fixed in the
beta.  It STILL does not discover a mouse.  Here is the output:
Running anaconda -please wait
Probing for video card...blahblah (found my video card)
Probing for something else...
Probing for mouse -- None - None
No mouse found -- forced into text mode installation

That is obviously paraphrasing but it still does not find the mouse.  

So at this point we know that it works in single-user mode with kudzu 0.99-10
and that it doesn't work when anaconda is run???

Guess I'll look at the anaconda source next....
Comment 11 Bill Nottingham 2005-02-04 17:44:30 EST
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please attempt to confirm with more recent releases.

Note You need to log in before you can comment on or make changes to this bug.