Bug 36669 - y2k bug in tar-1.13.17-8
Summary: y2k bug in tar-1.13.17-8
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-19 16:19 UTC by akonstam
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-19 21:01:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description akonstam 2001-04-19 16:19:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-22 i586)


If you execute:
tar -cvf ltx --newer='2001-01-01' <directory-name>

All files are tar-ed that are newer than Jan 01 2001.
However, if you execute:
tar -cvf ltx --newer='2000-01-01' <directory-name>
all files are tar-ed. The same thing happens is the satndard date format
like: Thu Apr 19 11:06:20 CDT 2001

It seems to happen with Year 2000 dates.


Reproducible: Always
Steps to Reproduce:
1.tar -cvf ltx --newer='2000-01-01' <directory-name>
2.
3.
	

Actual Results:  All files in directory are tarred even those before
01/01/2000

Expected Results:  Only files with dates after 01/01/2000 should be tarred

Comment 1 akonstam 2001-04-19 21:01:46 UTC
I appologize. This is certainly trtue on my machine but not on other machines I
tried this on using the same version of tar. I give up and you'all should
probably also give up trying to fix what seems to be a phantom problem.

Comment 2 Bernhard Rosenkraenzer 2001-04-20 22:16:34 UTC
Assuming your tar was compromised... Does this still happen on your machine if 
you reinstall the tar package?



Comment 3 akonstam 2001-04-25 14:25:43 UTC
I tried to remove the tar-1.13.17-8 and then reinstall it. The results werre the
same. That is 
the y2k bug remained. I am stumped. The delay in responding was because I was
out of town for 4 days.


Note You need to log in before you can comment on or make changes to this bug.