Bug 366691 - Regression/Crash: wpa_supplicant segfaults in usage with NetworkManager for WPA-Enterprise networks
Regression/Crash: wpa_supplicant segfaults in usage with NetworkManager for W...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 07:52 EST by Roland Wolters
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.5.7-16.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 22:38:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The /var/log/messages output (11.16 KB, text/plain)
2007-11-05 07:52 EST, Roland Wolters
no flags Details

  None (edit)
Description Roland Wolters 2007-11-05 07:52:19 EST
Description of problem:
I use my Laptop in a WPA-EAP/TTLS/TKIP/PAP environment. With NetworkManager 
0.6.x I was able to connect to the network, since the update to NetworkManager 
0.7.x this doesn't work anymore. Instead, /var/log/messages reports a segfault 
in wpa_supplicant.
If I deactivate NM and start wpa_supplicant manually with a manual generated 
configuration file everything works without a problem.

I tested with a normal WPA network from my home based router, that worked 
without problems.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.5.svn3030.fc8
wpa_supplicant-0.5.7-15.fc8

How reproducible:
Set up an enterprise WPA network like above and try to connect with it. The 
segfault appears every time for me.

Actual results:
The NetworkManager first tries to connect directly without asking for the 
login data since these are already stored. In the attached log file it can be 
seen that NM uses the login information for the new configuration - and 
wpasupplicant then crashes (at 13:31:20).
Afterwards, the supplicant is restarted (13:31:26), another login attempt is 
done but doesn't work for some reason, and the interface asks the connection 
details again (a Mark is set at 13:31:46 to highlight that point). The data 
are typed into the GUI, NM adds them to the configuration - and wpa_supplicant 
crashes again at 13:32:09.

Expected results:
NM should automatically detect the known network and automatically connect to 
it.
Comment 1 Roland Wolters 2007-11-05 07:52:19 EST
Created attachment 247931 [details]
The /var/log/messages output
Comment 2 Dan Williams 2007-11-05 09:58:54 EST
Any chance you could install wpa_supplicant-debuginfo, gdb attach to
wpa_supplicant as root, and get a backtrace of the segfault when it happens?
Comment 3 Roland Wolters 2007-11-05 10:51:54 EST
I created a full backtrace (bt full) with the help of gdb after I installed 
wpa_supplicant-debuginfo. However, before I upload it here, is there any 
chance that my password data of this network can be read out of the backtrace? 
In such a case the data have to be handled confidentially. Otherwise I would 
have to change my password first, make such a backtrace, and change the 
password back again.
Comment 4 Dan Williams 2007-11-06 11:08:39 EST
I don't believe so, but feel free to email it to me at my email address if you
want more privacy.  Even if your private key password is exposed, you can easily
change that with

openssl rsa -in private-key.pem -out nokey.pem
openssl rsa -in nokey.pem -out private-key.pem -des3

or similar.
Comment 5 Dan Williams 2007-11-13 12:05:05 EST
Can you try wpa_supplicant-0.5.7-16?

http://koji.fedoraproject.org/koji/taskinfo?taskID=239670
Comment 6 Fedora Update System 2007-11-14 22:38:55 EST
wpa_supplicant-0.5.7-16.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Roland Wolters 2007-11-15 06:46:56 EST
Dan, with the new wpa_supplicant there is no crash anymore. The login still 
doesn't work, though.
Should I close this bug and fill another bug because the login is not possible 
via NM atm?
As I said, using wpa_supplicant alone works without any problem.

Note You need to log in before you can comment on or make changes to this bug.