Bug 3667 - netfs restart crashes amd
netfs restart crashes amd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: am-utils (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-23 10:11 EDT by Luca Bonomi
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 22:50:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Bonomi 1999-06-23 10:11:46 EDT
We are using nfs mounted filesystems with the amd.
If netfs daemon is restarted, the automounted filesystems
are not reachable anymore.

While stopping netfs, you get the message that it cannot
unmount the am-fs because are busy.

Trying to restart the amd do not help in any way. The only
solution is to log out, enter a console as root, unmount
(with 'umount' command) the am-fs, and restart the amd.

It would be nicer if netfs could handle these situations.
:-)
Comment 1 Cristian Gafton 1999-07-28 03:23:59 EDT
assigned to jbj
Comment 2 Bill Nottingham 1999-08-31 12:41:59 EDT
the netfs isn't a daemon ; it's simply something that mounts/unmounts
network filesystems.  It shouldn't need 'restarted' per se. Why
are you doing a 'netfs restart'?
Comment 3 Anonymous 1999-09-06 09:14:59 EDT
I discovered the bug by chance, while trying out things...
Running a 'netfs restart' or 'netfs stop' while someone is accessing
the am directories causes the amd to crash. I have seen it several
times, and every time I had to log out to restore it.

It's not a serious bug, because as you wrote there should be no need
to issue 'netfs restart'. But anyway, I still believe it's a bug! At
least, there should be no possibility to run 'netfs stop' if it's not
needed!

It might be that the bug is in amd. Namely, when you try to unmount an
am directory which is accessed, then the amd crashes.
Comment 4 Cristian Gafton 2000-08-08 22:45:25 EDT
assigned to nalin
Comment 5 Brent Fox 2002-06-05 11:46:17 EDT
Closing due to old age.  Please reopen if you see the behavior in the latest
release.

Note You need to log in before you can comment on or make changes to this bug.