Bug 36671 - kernel build fails
kernel build fails
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-19 13:11 EDT by Neal D. Becker
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-26 08:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Neal D. Becker 2001-04-19 13:11:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686; Nav)

kernel make modules fails

Reproducible: Always
Steps to Reproduce:
1.make modules

Actual Results:  make modules
make -C  kernel CFLAGS="-D__KERNEL__ -I/usr/src/linux/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing
-fno-common -Wno-unused -pipe -mpreferred-stack-boundary=2 -march=athlon 
-DMODULE -DMODVERSIONS -include /usr/src/linux/include/linux/modversions.h"
make[1]: Entering directory `/usr/src/linux-2.4.2/kernel'
make[1]: Nothing to be done for `modules'.
make[1]: Leaving directory `/usr/src/linux-2.4.2/kernel'
make -C  drivers CFLAGS="-D__KERNEL__ -I/usr/src/linux/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing
-fno-common -Wno-unused -pipe -mpreferred-stack-boundary=2 -march=athlon 
-DMODULE -DMODVERSIONS -include /usr/src/linux/include/linux/modversions.h"
make[1]: Entering directory `/usr/src/linux-2.4.2/drivers'
make -C atm modules
make[2]: Entering directory `/usr/src/linux-2.4.2/drivers/atm'
gcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=athlon  -DMODULE -DMODVERSIONS -include
/usr/src/linux/include/linux/modversions.h -g  -c -o eni.o eni.c
In file included from eni.c:6:
/usr/src/linux/include/linux/module.h:173: nondigits in number and not
/usr/src/linux/include/linux/module.h:173: nondigits in number and not
/usr/src/linux/include/linux/module.h:173: nondigits in number and not
/usr/src/linux/include/linux/module.h:173: nondigits in number and not
/usr/src/linux/include/linux/module.h:173: parse error before `62dada05'
`inter_module_register_R_ver_str' declared as function returning a function
/usr/src/linux/include/linux/module.h:173: warning: function declaration
isn't a prototype

Here is preprocessed output:

# 173 "/usr/src/linux/include/linux/module.h"
extern void inter_module_register_R_ver_str(62dada05)(const char *, struct
module *, const void *);
extern void inter_module_unregister_R_ver_str(7a9e845e)(const char *);
extern const void *inter_module_get_R_ver_str(f6a0ce24)(const char *);
extern const void *inter_module_get_request_R_ver_str(b69f826b)(const char
*, const char *);
extern void inter_module_put_R_ver_str(6b99f7d8)(const char *);
Comment 1 Arjan van de Ven 2001-04-19 13:21:25 EDT
What .config file did you use?
And did you do a "make mrproper" before starting to build ?

eg the sequence should be:

make mrproper
cp configs/kernel-2.4.2-XXXX.config .config
make oldconfig
make dep
make bzImage
make modules
Comment 2 Przemyslaw Karwasiecki 2001-04-25 22:02:18 EDT
I have the very same problem.

It is happening when I have created new .config file 
with `make menuconfig' and also when I was using
a copy of folowing file:

Comment 3 Arjan van de Ven 2001-04-26 04:36:10 EDT
Did you do a make mrproper before starting?
Comment 4 Arjan van de Ven 2001-04-26 08:23:20 EDT
OH by the way, if you want an athlon kernel, doing

rpm --rebuild --target=athlon kernel-2.4.2-2.src.rpm

will generate a kernel rpm optimised for athlons.
Comment 5 Neal D. Becker 2001-04-26 08:31:03 EDT
It is OK now, I'm not sure if make mrproper fixed it.

BTW, I have avoided --target=athlon previously with RH7.0 because it wasn't 
handled correctly.  I haven't tried it with the kernel, but if you did this
to an arbitrary application it would just cause confusion when rpm thought it 
shouldn't install the package because it was the wrong target.
Comment 6 Arjan van de Ven 2001-04-26 08:32:44 EDT
That is supposed to be fixed.
And for the kernel, we even made a special athlon .config file.
Comment 7 Przemyslaw Karwasiecki 2001-04-26 11:31:56 EDT
Thank you,

make mrproper have fixed it.


Note You need to log in before you can comment on or make changes to this bug.