Bug 36675 - eroaster unable to extract information from ISO image
eroaster unable to extract information from ISO image
Status: CLOSED WORKSFORME
Product: Red Hat Powertools
Classification: Retired
Component: eroaster (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 14:19 EDT by Yaron Minsky
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 09:45:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaron Minsky 2001-04-19 14:19:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.8.1)
Gecko/20010327


If you try to extract info from an ISO image, it fails producing the
following stacktrace:

Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/eroaster/main.py", line 2239, in ImageInfo
    output = striplist(pipe[0].readlines())
IOError: (0, 'Error')

On the face of it, the code in question looks fine --- if I just open
python, create the pipe and read from it, it works without problems.  So
it's not clear to me what is causing the error.

Also, this error makes it impossible to burn directly form an ISO image,
which is a pain.

Reproducible: Always
Steps to Reproduce:
1.Click on the "ISO Image" tab in eroaster
2.click on browse to select an ISO image
3.click on "image info"
Comment 1 Tim Powers 2001-04-19 14:31:14 EDT
I can't reproduce this. I tried it on a few different ISOs and it works fine. I
tried it against the Powertools 7.1 ISO, and a few different distro ISO images
with no tracebacks occurring.

Can you let me know if this fails on other ISO images as well?

Tim
Comment 2 Yaron Minsky 2001-04-19 16:26:58 EDT
I tried it on a few ISO's, and I even created a new one (using eroaster) and hit
the same problem.

It's very odd.  It's getting an IOError, presumably when trying to read the
output from isoinfo.  I don't see any reason why it should be doing that. I'm
also having trouble thinking of a good way of instrumenting the code to figure
out what's going on.
Comment 3 Yaron Minsky 2001-04-19 16:29:05 EDT
A further comment.  I tried switching to commands.getouput instead of using
a naked popen2 command to get a pipe.  It was no different.  Also,
I modified the code so that it tried to invoke ls instead of isoinfo.  It had
the same problem.  So it is the reading of data form a pipe that's breaking,
for some odd reason.  But if I just start a naked python shell and try to do the
same thing, everything works dandy.  Weird.
Comment 4 Yaron Minsky 2001-04-19 16:39:26 EDT
One final note.  I tried putting a few different commands in there.  I get
different errors each time.  For ls I get errno 10, "no child processes".  For
"sleep 5" and "echo foo", I get errno 4, "Interrupted system call".
Comment 5 Tim Powers 2001-04-23 09:45:11 EDT
I still can't reproduce this here.

Tim

Note You need to log in before you can comment on or make changes to this bug.