Bug 36676 - XMMS segfault on RH7.1
XMMS segfault on RH7.1
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2001-04-19 14:33 EDT by Matt Biermann
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-24 13:12:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matt Biermann 2001-04-19 14:33:55 EDT
XMMS 1.2.4-13 that ships with RedHat 7.1 segfaults on upgraded 7.0 
system.  Sometimes, XMMS segfaults directly on execution, other times 
directly on shutdown.

Base RH 7.1 system P3 500mhz directly after upgrade
Comment 1 Peter Jones 2001-04-21 14:48:23 EDT
Seems to happen at song transition as well on my k7-700 with an emu10k1, using
esd or not.
Comment 2 Need Real Name 2001-05-01 13:06:56 EDT
Even the self-kompiled xmms-1.2.4 from xmms.org seg. faults on songchange...  
I tried to compile it egcs too, but same fault... 
is it glibc once again?
Comment 3 Bill Nottingham 2001-05-01 13:47:07 EDT
Every time the song changes?  Any messages in syslog?
(it's working fine for me here...)
Comment 4 Need Real Name 2001-05-01 15:20:52 EDT
when using xmms-1.2.4-13.i386.rpm (from rh71-contrib), XMMS hangs during songchange, either manual og automatic.  On the terminal it says "Minnesegmentsfeil"(Norwegian for segfault). Syslog says nothing. 
After that I must take a killall -9 xmms.
Sometimes it crashes on startup.

The system is a AMD Duron 750, upgraded from rh70.  It worked perfectly earlyer.

Same thing happens when I compile xmms myself, from tarball downloaded at www.xmms.org.  As said earlyer, I tried to compile it with egcs, but it didn't help..
Comment 5 Bill Nottingham 2001-05-02 01:33:48 EDT
All of these are on upgrades from 7.0? Hm.

What does rpm -q glibc gtk+ Mesa XFree86-libs glib vorbis libogg mikmod libxml zlib
say? (i.e., are you sure they're all the 7.1 versions.)

Do any of them verify oddly?

I can't reproduce this here, even on an athlon machine, but it's a fresh install.
Are you using any non input/output plugins?
Comment 6 Need Real Name 2001-05-02 08:50:25 EDT
I fixed it!!  
I uninstalled the package with rpm -e xmms, and manually deleted 
/usr/lib/xmms/ and /usr/share/xmms/..
When I installed it again, it worked with no complains.. 

Comment 7 Nadeem 2001-05-05 01:15:35 EDT
I was also having xmms segfault on me during song changes. I followed 
knut.magne@solem.as's advice and it seems to work fine now. I know I compiled
some xmms plugins myself on 7.0. So perhaps upgrading to 7.1 caused some
problems with these plugins which were compiled against 7.0 libs. I didn't check
each individual plugin to find out which one it was, I had quite a few
Comment 8 pi 2001-05-08 04:43:26 EDT
I had the same problem updating from 7.0 to 7.1. With a clean new 7.1 
installation I had no segfault problem, but the streaming stops in the middle 
of a song and jumps to another again and again when playing mp3 files from a 
recorded cd. Does anyone have the same problem?
Comment 9 Peter Jones 2001-05-09 01:52:13 EDT
Ok, on my Athlon it seems to be because of stale plugins that were built
seperately from the package.  Goes away if I rpm -e xmms, kill the /usr/lib/xmms
directory by hand, and rpm -Uvh xmms.
Comment 10 James Cook 2001-06-01 11:40:00 EDT
oh, here's a surefire way to make xmms crash ... hit the up or down arrow with
the window active.  xmms goes *poof*
Comment 11 John Nelson 2001-06-19 14:54:22 EDT
I seem to be having the same problem.  Sometimes XMMS wedges on song
transitions.  Very often it wedges when doing "Play Directory" from the menu. 
Much of the time a core is dropped in my home directory although the binary for
this core seems to be kdeinit.

Today I started getting the following errors from XMMS when executing from the
command line.  I removed the .esd directory and now all seems to be well,
however the symptoms don't seem to be consistant....

[john@thymine ~]$ /usr/bin/xmms
esd: Failed to fix owner of /tmp/.esd.
Try -trust to force esd to start.
esd: Esound sound daemon unable to create unix domain socket:
The socket is not accessible by esd.
esd: Failed to fix owner of /tmp/.esd.
Try -trust to force esd to start.
esd: Esound sound daemon unable to create unix domain socket:
The socket is not accessible by esd.
Comment 12 John Nelson 2001-06-22 15:48:45 EDT
Oh boy it gets worse and worse... XMMS now wedges after only a few tunes and
sometimes on launch.  It has something to do with "ESD" because I can clear the
problem by removing /tmp/.esd.  And check *this* out from the terminal....

[john@thymine /tmp]$ /usr/bin/xmms &
[3] 1550
[john@thymine /tmp]$ Unable to connect to UNIX socket /tmp/.esd/socket

It just loses the socket.

-- John
Comment 13 Bill Nottingham 2002-01-15 17:34:24 EST
The ESD thing is probably a dupe of 53123. Marking as closed->wontfix; the
original reported problems were due to non-RH plugins, which is not something we
can really support.

Note You need to log in before you can comment on or make changes to this bug.