Bug 366761 - problem with update to most recent bind packages
problem with update to most recent bind packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 08:41 EST by Christian Krause
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 09:32:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2007-11-05 08:41:12 EST
Description of problem:
the automatic update of all bind packages (bind-libs, bind-utils, ...) is broken
(using e.g. yum update)

Version-Release number of selected component (if applicable):
bind-libs-9.4.2-0.4.rc1.fc7 (installed)
bind-libs-9.4.2-0.2.b1.fc7 (in F7-updates)

How reproducible:
100%

Steps to Reproduce:
1. have bind-libs-0.4.2-0.4.rc1.fc7 installed (This was not done manually, most
likely it just happened during a former "yum update" call)
2. try yum update - nothing gets updated
or try update manually: 
 rpm -U /fedora-core/updates/7/i386/bind-libs-9.4.2-0.2.b1.fc7.i386.rpm
/fedora-core/updates/7/i386/bind-utils-9.4.2-0.2.b1.fc7.i386.rpm 
/fedora-core/updates/7/i386/bind-9.4.2-0.2.b1.fc7.i386.rpm 
        package bind-libs-9.4.2-0.4.rc1.fc7 (which is newer than
bind-libs-9.4.2-0.2.b1.fc7) is already installed
        package bind-utils-9.4.2-0.4.rc1.fc7 (which is newer than
bind-utils-9.4.2-0.2.b1.fc7) is already installed
        package bind-9.4.2-0.4.rc1.fc7 (which is newer than
bind-9.4.2-0.2.b1.fc7) is already installed

  
Actual results:
nothing gets updated, because a formerly installed version (9.4.2-0.4.rc1.fc7)
is treated newer as the newest version in F7-updates

Expected results:
the package should be updated to the newest version of the package in F7-updates

Additional info:
I assume that for a short amount of time the mentioned version
(9.4.2-0.4.rc1.fc7) was available in the F7-updates, got updated and is now
treated as newer than the newest version in F7-updates.

I'm setting the severy to high, because this problem blocks security updates of
bind without telling the user.
Comment 1 Adam Tkac 2007-11-05 09:32:17 EST
Hm, 9.4.2-0.4.rc1 should be in F7 updates and it is latest F7 version (and it
was released so this is why you have that version installed). I'm not sure why
F7-updates contains 9.4.2-0.2.b1 but problem should be fixed in today update.
Thanks for report

Note You need to log in before you can comment on or make changes to this bug.