Bug 36688 - xmms preferences window & skin chooser window refuse to handle mouse
xmms preferences window & skin chooser window refuse to handle mouse
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 16:31 EDT by Anvil
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 14:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anvil 2001-04-19 16:31:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.4.3 i686)


When openning the xmms preferences window, I just cannot use my mouse and
click in the window.. I hear some *beep* and this message in my
~/.xsession-errors "Error: Stacking constraint failed". I'm almost sure
this bug is in sawfish.. It cannot be in xmms like i thought first because
when I launch xmms from an xterm (not from my gnome-panel) the error is
still in my ~/.xsession-errors. I configured sawfish to beep on error and
when i click in this window i hear beep.
I use absolute-e theme in sawfish (if this may help..)

Reproducible: Sometimes
Steps to Reproduce:
1. Launch gnome+sawfish
2. launch xmms.
3. Ctrl-p to open preferences window in xmms
4. try to click in this window.
	

Actual Results:  I hear beep and my ~/.xession-errors contains one more
"Error: Stacking constraint failed"


Expected Results:  I should be able to click in this window to modify xmms
preferences..


If you want some config (like ~/.sawfish directory) files of mine, just
ask.
I am logged in for 5 days now without restarting X or sawfish and IIRC
yesterday i didn't have this problem.
Comment 1 Anvil 2001-04-19 16:33:05 EDT
IIRC (still), I had this problem once with wolverine or fisher...
Comment 2 David Mason 2001-04-19 16:47:00 EDT
I cannot reproduce this at all - xmms shows no errors and there are no errors in
the .xsession-errors file. Do you try to handle xmms windows any particular way
in your .sawfishrc or sawfish preferences? what about transient windows?
Comment 3 Diego Novillo 2001-04-25 10:41:09 EDT
I'm getting the exact same behaviour. I'm trying to add a directory to xmms's
playlist. The directory window opens up but it refuses to accept any mouse input
(not even the scrollbar works). Keyboard input is processed, though.

I'm using sawfish and launch gnome using 'startx'. I get the same error messages
in my X log file. My X session is also long lived, but I can reproduce this
behaviour every time, regardless of how long I've been using X.
Comment 4 Anvil 2001-04-25 14:01:24 EDT
If you wanna check my config files see http://confiote.ath.cx/~anvil/config.tar.gz
It contains my .gnome* and .sawfish* directories

P.S : i dont know what's a transcient window.. :(
Comment 5 Havoc Pennington 2001-07-12 14:39:50 EDT
Upstream as http://bugzilla.eazel.com/show_bug.cgi?id=8412

It's probably some xmms braindamage, though sawfish should be able to 
wrangle xmms without beeping.

Closing on RH level
Comment 6 Jeremy Nickurak 2001-08-30 01:26:04 EDT
Very similar bug as listed on the XMMS's bugzilla. One solution/workaround given:
http://bugs.xmms.org/show_bug.cgi?id=27

Note You need to log in before you can comment on or make changes to this bug.