Bug 36690 - G450 installation fails to return after X video test
G450 installation fails to return after X video test
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 17:13 EDT by Panic
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-10 21:44:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-04-19 17:13:18 EDT
During installation with a Matrox G450 video card, everything goes well
until the installer tries to return to the installation after the video
test.  At this point, my monitor goes blank, then prints a message saying:

MONITOR IS WORKING

SYNC IS OUT OF RANGE

and stays there.  I'm assuming the installation is still going on, but
since I can't see it...

Monitor is a Dell P991, Machine is a Dell Precision 420 MT (2xP3-733,
256MB).  lspci -vb output on the card:

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev
82) (prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc.: Unknown device 0641
        Flags: medium devsel, IRQ 9
        Memory at f4000000 (32-bit, prefetchable)
        Memory at fcffc000 (32-bit, non-prefetchable)
        Memory at fc000000 (32-bit, non-prefetchable)
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0

lspci -vn output of the card:

01:00.0 Class 0300: 102b:0525 (rev 82)
        Subsystem: 102b:0641
        Flags: medium devsel, IRQ 16
        Memory at f4000000 (32-bit, prefetchable) [size=32M]
        Memory at fcffc000 (32-bit, non-prefetchable) [size=16K]
        Memory at fc000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at 80000000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0

The problem is easily bypassed by skipping the X test, once it is confirmed
that X is working the first time around.

Reproduceable:  Always (the three times I tested it).

Steps to reproduce:

1. Start 7.1 installation on this Dell Precision 420 MT.
2. Choose 24bit 1280x1024 during X setup, test works fine.
3. Upon attempting to return to the installation, the monitor goes blank.

The machine is available for testing if necessary.
Comment 1 Panic 2001-04-19 17:17:01 EDT
Forgot -- this seems similar but not exactly like 26677 -- might be a duplicate,
but it seemed different enough that I opened a new bug.
Comment 2 Alexei Podtelezhnikov 2001-04-21 15:28:02 EDT
Do you find it normal that you think that you have G450, but lspci thinks it's 
a G400? How do we reconcile this?
Comment 3 Panic 2001-04-23 11:20:09 EDT
Well, yes. :)  We received these G450s about 4 or 5 months ago, when G450
support was really weak.  We tried to get them replaced from Dell, but nothing
has come of that yet.  Most of us got them working one way or another with the
beta drivers from Matrox.  The support in 7.1 (XFree 4.0.3) is much better, but
apparently the kernel still doesn't identify this particular card correctly --
which is a (small) problem in and of itself.  We know for a fact that this is a
G450, but they are Dell machines -- maybe a Dell PCI ID change?

Here's what the /usr/share/kudzu/pcitable says about the G400 and the G450:

0x102b  0x0521  "Card:Matrox Millennium G200"   "Matrox|MGA G200 AGP"
0x102b  0x0525  "Card:Matrox Millennium G400"   "Matrox|MGA G400 AGP"
0x102b  0x0525  0x102b  0x0541  "Card:Matrox Millennium G450" "Matrox|MGA G450
DualHead"
0x102b  0x0525  0x102b  0x0542  "Card:Matrox Millennium G450" "Matrox|MGA G450
DualHead LX"
0x102b  0x0525  0x102b  0x0641  "Card:Matrox Millennium G450" "Matrox|MGA G450
DualHead"

You'll note that my G450 is in there (if I'm reading this right) but the lspci
listing apparently defaults back to the G400 listing (0x102b 0x0525), and lists
0x0641 as unknown.  This may be a difference between what kudzu is listing and
what the kernel is going by, which I agree seems strange.  Mike?
Comment 4 Mike A. Harris 2002-03-10 21:44:46 EST
The kernel has nothing to do with video card identification.  The problem
is only cosmetic.  Matrox in all of their wisdom, made the G400 and G450 use
the same PCI ID.  The PCI ID is what makes the card unique, so both cards
get detected as G450.

When XFree86 detects the card, it does the right thing for G450 however, but
displays G400.  It is only cosmetic, and fixing this is not worth the effort.

Fixing the bug however is.  ;o)

I have a G450, however it does not work on any of my 3 AGP 2x machines, so
I am unable to test it.  What's more is Matrox does not release the specs
for G450.

Does this problem occur in rawhide XFree86 4.2.0?
Comment 5 Mike A. Harris 2002-11-07 07:29:30 EST
I believe this problem is caused due to Matrox hardware flaws which
the card does not operate in certain AGP modes on certain motherboards.

The suggested workaround, is to set your AGP mode to 1x in the BIOS
CMOS settings, and use the AGPmode directive in the X config file to
set it to 1 as well.  If that doesn't work, change *both* to AGP 2x
by rebooting and changing CMOS, etc. again.  Then try AGP 4x.

If any of these options work, please indicate what ones worked (please
try all combinations).  Also include the output of dmi-decode.

If none of these options work, please upgrade to Red Hat Linux 8.0,
and see if the problem persists there.  If so, please try the latest
rawhide XFree86.  If none of these options work, and this problem
is still relevant to you, please reopen the bug and we will do deeper
troubleshooting.

I've got a Matrox G450 working on a board here in 8.0, so I'm closing this
as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.