Bug 36698 - XCDRoast fails silently when started as non-root user
XCDRoast fails silently when started as non-root user
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xcdroast (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Karsten Hopp
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 19:08 EDT by Yaron Minsky
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 11:15:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (113.94 KB, text/plain)
2001-05-03 11:15 EDT, Yaron Minsky
no flags Details

  None (edit)
Description Yaron Minsky 2001-04-19 19:08:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.8.1)
Gecko/20010327


When a non-root user launches xcdroast from the command line, it silently
fails, giving no hint as to why.  When launched from the start menu, xalf
gets going, but it never finishes launching.  When xcdroast fails to launch
because it was launched as a non-root user, it should give a message to
that effect.

Reproducible: Always
Steps to Reproduce:
1.type "xcdroast"
2.hit return
Comment 1 Karsten Hopp 2001-05-02 07:49:39 EDT
I can reproduce this only if I try to run xcdroast after a 'su - username'
Is this what you are trying to do ?
Comment 2 Yaron Minsky 2001-05-02 08:44:40 EDT
Nope.  This happens if I launch xcdroast as a regular user.
Comment 3 Karsten Hopp 2001-05-03 06:31:51 EDT
Can you start other consolehelper enabled tools such as apache-config as
a normal user ?
Can you send me a strace output (strace -f -F -s200 -p <pid of process>) of
xcdroast ?
Comment 4 Yaron Minsky 2001-05-03 11:15:06 EDT
Created attachment 915078 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 5 Karsten Hopp 2001-05-22 07:54:12 EDT
A normal user is not supposed to have /sbin or /usr/sbin in the PATH.
If you absolutly have to add these directories to your PATH variable, 
add them at the end of the searchpatch, not at the front !
If you call /usr/bin/xcdroast instead of /usr/sbin/xcdroast, everything should
work fine.

Note You need to log in before you can comment on or make changes to this bug.