Bug 366991 - totem can't play DVDs with Movie -> Play Disc
totem can't play DVDs with Movie -> Play Disc
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 11:14 EST by Ben Konrath
Modified: 2008-04-01 09:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 11:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Konrath 2007-11-05 11:14:46 EST
Description of problem:

totem can't pay DVDs with Movie -> Play Disc but can play DVDs with Movie ->
Open Location -> 'dvd://1'

Version-Release number of selected component (if applicable):

totem-2.20.1-1.fc8

How reproducible:

Always

Steps to Reproduce:
1. With DVD in the drive, open totem and do Movie -> Open Disc. This will
   give the following error message:

Totem cannot play this type of media (DVD) because it does not have the
appropriate plugins to be able to read from the disc.

2. Click OK, and then do Movie -> Open Location
3. Enter dvd://1 and the movie will start playing
Comment 1 Bastien Nocera 2007-11-05 11:41:40 EST
dvd://1 plays only the first track, and doesn't offer menus, which is what
people expect nowadays. GStreamer upstream needs to support menus before it can
work as you expect.

Also, dvd://1 will show problems with the sound when switching languages, and
plenty of other fun bugs.

In all cases, we don't ship any of the plugins necessary to play back DVDs.
Comment 2 Ben Konrath 2007-11-08 00:31:11 EST
I was using a home-made non-ecrypted DVD which I think can be played back with
the software shipped with Fedora (although I have not tested this). IMO if a DVD
works with dvd://1, it should be allowed to play with Movie -> Play Disc. Better
to have partial support than none at all. But as the application developer,
that's your call :-) 

As an aside, I ran into this issue when I was trying to play a training video
for a course I took. The DVD wasn't working with the instructor's laptop so I
offered my laptop instead. I felt pretty lame when things didn't work and even
lamer when I had to enter the URI to get it work. After the class, a couple of
people were interested in "the strange" programs on my computer. They also
noticed that I had to type in some "secret code" to get the DVD to play. I
couldn't help feeling that this incident really just reinforced what they had
heard about linux - that's it's hard to use. Anyway, just thought I'd share this
little story - thanks for your comment. Cheers, Ben
Comment 3 Bastien Nocera 2008-04-01 09:20:28 EDT
FYI, this is fixed in Totem 2.23.0 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.