Bug 367191 - "service sshd restart" - fails on fresh install of Fedora 8
"service sshd restart" - fails on fresh install of Fedora 8
Status: CLOSED DUPLICATE of bug 364971
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
8
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 13:05 EST by Mike A. Harris
Modified: 2010-11-09 18:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 18:39:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SElinux audit log (12.67 KB, text/plain)
2007-11-05 13:23 EST, Mike A. Harris
no flags Details

  None (edit)
Description Mike A. Harris 2007-11-05 13:05:10 EST
Description:

On a fresh OS install of Fedora 8 (leaked from a mirror), the sshd service
starts up at boot time, but can not be restarted afterward by the initscript:

[root@hammer ~]# service sshd status
sshd (pid 1900) is running...
[root@hammer ~]# service sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied
                                                           [FAILED]
[root@hammer ~]# service sshd start
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied
                                                           [FAILED]
[root@hammer ~]# service sshd start
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied
                                                           [FAILED]



Version-Release number of selected component (if applicable):
[root@hammer ~]# rpm -qa |grep openssh
openssh-server-4.7p1-2.fc8
openssh-4.7p1-2.fc8
openssh-askpass-4.7p1-2.fc8
openssh-clients-4.7p1-2.fc8


How reproducible:
100%

Additional information:
If I just run "/usr/sbin/sshd" by itself, it does start up, but of course
not without the commandline arguments it normally starts with, etc.
Comment 1 Mike A. Harris 2007-11-05 13:14:56 EST
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
Comment 2 Mike A. Harris 2007-11-05 13:16:06 EST
selinux-policy-3.0.8-44.fc8
selinux-policy-targeted-3.0.8-44.fc8
setroubleshoot-plugins-1.10.3-1.fc8
setroubleshoot-1.10.7-1.fc8
setroubleshoot-server-1.10.7-1.fc8
Comment 3 Mike A. Harris 2007-11-05 13:23:00 EST
Created attachment 248511 [details]
SElinux audit log
Comment 4 Mike A. Harris 2007-11-05 13:35:39 EST
[root@hammer tmp]# restorecon /usr/sbin/sshd
[root@hammer tmp]# restorecon /etc/init.d/sshd
[root@hammer tmp]# service sshd restart
Stopping sshd:                                             [FAILED]
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied
                                                           [FAILED]
Comment 5 Will Woods 2007-11-05 15:35:41 EST
Could be a duplicate of bug 364971 - can you try the fix mentioned there?
Comment 6 Jason Farrell 2007-11-05 18:15:09 EST
This affected me as well, but Dan Walsh's fix from
https://bugzilla.redhat.com/show_bug.cgi?id=364971#c5 did the trick:

[root@nano ~]# setenforce 0
[root@nano ~]# /etc/init.d/sshd restart
Stopping sshd:                                             [FAILED]
Starting sshd:                                             [  OK  ]
[root@nano ~]# setenforce 1
[root@nano ~]# /etc/init.d/sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied
                                                           [FAILED]
[root@nano ~]# semanage user -m -r s0-s0:c0.c1023 unconfined_u
[root@nano ~]# /etc/init.d/sshd restart
Stopping sshd:                                             [FAILED]
Starting sshd:                                             [  OK  ]
Comment 7 Tomas Mraz 2007-11-05 18:39:45 EST

*** This bug has been marked as a duplicate of 364971 ***

Note You need to log in before you can comment on or make changes to this bug.