Bug 3672 - Performance bugs in syslogd and klogd
Performance bugs in syslogd and klogd
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sysklogd (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-23 11:03 EDT by mch
Modified: 2014-03-16 22:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-05 12:58:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mch 1999-06-23 11:03:21 EDT
Hello.

Both syslogd and klogd take much cpu (>10%) without much
output to the log files.

Is there a newer version of sysklogd, or do you know
of any fixes to /etc/syslog.conf that fixes this problem
(i'm using /etc/syslog.conf from RH6.0/x86).

/Magnus
Comment 1 Jay Turner 1999-06-23 11:14:59 EDT
Unable to find this on any of our servers, but am forwarded it to a
developer for further review.
Comment 2 Bill Nottingham 1999-07-26 15:54:59 EDT
Does turning off syncing the file help at all?
Comment 3 mch 1999-07-27 03:52:59 EDT
Haven't tried that. The weird thing is that there isn't much logging
activity going on (less than 100 entries per day in messages and
hardly any entries at all in the other log files). The problem only
shows up when the machine is heavily loaded (load avg well over 1 for
long periods of time).

This problem has been discussed on the linux kernel mailing list, and
I was just wondering if you guys had a fix for it.

Thanks,

Magnus
Comment 4 mch 1999-08-02 06:06:59 EDT
I've tested turning off syncing now, and it does not help.

/Magnus
Comment 5 Jeff Johnson 1999-09-05 12:58:59 EDT
I see no way to address this request without some idea of what
the cause of the cpu usage is. AFAICT, it's quite possible for
syslogd to receive messages, possibly multiple times a second,
that, because of the configuration in /etc/syslog.conf, are simply
discarded. Please reopen this bug if you have specific suggestions
to reduce cpu usage.

Note You need to log in before you can comment on or make changes to this bug.