Bug 36758 - postscript printing still not working
postscript printing still not working
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-04-20 03:55 EDT by Levente Farkas
Modified: 2007-03-26 23:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-18 16:37:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2001-04-20 03:55:28 EDT
as I reported in wolworine and after wolworine I reported it for rawhide
postscript printing still not working on out HP laserjet 5m in rh 7.1.
this's not a noname printer it's one of the most widely used HP laserjet
printer! when I try to print poscript I've got a "40 HP MIO ERROR" on
the printer and the job was removed from the local spool.
If it's not possible to solve it could you suggest me another printer
daemon implementation? my wokmates laugh at me and said "it's work
for me on windows since windows 3.1" and the said thing it's true.

ps. not to mention that there is still not an option for printing 2
pages to one page (which was in the old rh 6.2 printtool's days).
this is still also working on windows:-(((((
Comment 1 juha.heljoranta 2001-05-15 08:38:58 EDT
printconf can not save driver option "Render Postscript". Driver is lj5gray and my printer is HP LaserJet 6L.

This is what I have found out:

from file /var/spool/lpd/HP_LaserJet_6L/mf.cfg
--- clip ---
define(PSfilter, `filter /usr/share/printconf/util/mf_postscript_wrapper  --mfomatic -d lj5gray-62368.foo')dnl
--- clap ---

and while trying to..
--- clip ---
[root@localhost foomatic]# /usr/share/printconf/util/mf_postscript_wrapper  --mfomatic -d lj5gray-62368.foo
--mfomatic -d lj5gray-62368.foo
-d lj5gray-62368.foo
Case 3

mfomatic backend version $Revision running...
/usr/share/printconf/foomatic/mfomatic: called with arguments: '-d','lj5gray-62368.foo'
/usr/share/printconf/foomatic/mfomatic: options: ''
/usr/share/printconf/foomatic/mfomatic: printer def file lj5gray-62368.foo
/usr/share/printconf/foomatic/mfomatic: unable to evaluate datablob
error in datablob eval at /usr/share/printconf/foomatic/mfomatic line 112.
--- clap ---

I hope that this info helps..
Comment 2 William W. Austin 2001-05-15 13:02:54 EDT
I am having a problem which is possibly related.  Again it is not an offbrand
printer, but an HP LJ4M with 26 MB of memory (for larger PS documents).

The printer is set up to use the postscript driver. 

If I send a multi-page document to the printer, the final page will *never*
print, and sometimes ONLY the first page will print.  If I break the document
down into individual pages (from, for instance, Applix Words or Kword), randomly
pages will not print.  I can see them in the queue, I hear the disk accesses as
they are 'sent' to the printer, and the printer receiving light blinks, but
nothing ever comes out. 

Having just gotten a workaround for another printer bug (38430) which involved
the backwards nature of the \n -> \r\n translation, I am wondering if that could
be a reversal here.
If I try multiple copies, parts of the first one will print, but thereafter only
an occasional first page will print.

The described behaviour is identical whether I directly connect the printer to
my linux box or use it on the extenral jet direct box.

Interestingly enough, if I remove the 7.1 printer rpms (LPRng, printconf,
printconf-gui) and re-install the 7.0 rpms (LPRng, printtool, rhs-printfilters)
the printer works just fine in postscript mode, and I can send the same,
files and have them print correctly.  I have tried various combinations under
printconf-gui (to send formfeed or not, to translate \n to \n\r or not, others)
but have not yet hit on a combination which works in PS mode.

I also tried the plain (generic) postscript driver, and it too fails, too. 
Unfortunately the useful generic postscript driver from 7.0 which allowed the
user to specify resolution (300,600dpi,etc) 2 pages printing on 1 page, etc.,
are also not implemented in the new driver.

Comment 3 William W. Austin 2001-05-15 13:12:35 EDT
Oops. I left out two items here in the note I just added.  Sorry

A) as above, printconf does not save the driver option "Render Postscript". 

B) The log indicates:

> IF filter 'mf_wrapper' filter msg - '/usr/share/printconf/foomatic/mfomatic:
called with arguments: '-d','Postscript-69120.foo'' at 2001-05-15-00:00:14.346
## A=bill@baustin+688 number=688 process=21718
Comment 4 Tim Waugh 2002-01-18 16:37:07 EST
Please let me know if the following packages fix this problem.  They are 
errata candidate packages; that is, they have not been through QA yet, but I 
think they may fix the multi-page problem.

Comment 5 Tim Waugh 2002-03-05 12:17:16 EST
No feedback, closing.  Please re-open if this problem is not fixed by 7.2+updates.

Note You need to log in before you can comment on or make changes to this bug.